[linux-dvb] Pundit-R Avermedia 771 DVB IRQ lockup

Stephen Greszczyszyn sgreszcz at yahoo.com
Thu Mar 23 09:43:36 CET 2006


PROBLEM SOLVED

I downloaded, compiled, and installed the latest DVB
drivers and now everything works great with
MythTV0.19.  I may have had these driver problems
before, but for some reason they didn't affect the
channel changing/locking with myth0.18 - strange.

I'm happy now that everything is back and working
after the upgrade.  Thanks!


--- Edgar Toernig <froese[at]gmx[dot]de> wrote:

> Stephen wrote:
> >
> > I have an Asus Pundit-R barebones which I'm using
> with
> > Ubuntu Linux (kernel 2.6.12-10-686) and Avermedia
> 771
> > DVB-T card and MythTV as a PVR.  
> >
> > I recently upgraded to MythTV0.19 and had some
> > problems with tuning the channels.
> >...
> >... bt878(0): irq FBUS risc_pc=366f5008
> 
> Did you never had that message in the logs before??
> I can't imaging how changing MythTV version could
> cause
> these errors.
> 
> 
> > I have been reading that the Avermedia 771 does
> not
> > like sharing IRQs.  Is there any way to prevent
> this
> > IRQ lockup from happening?
> 
> It has nothing to do with IRQ sharing.  The Bt878
> couldn't
> get the PCI bus and his FIFO overflows.  That error
> isn't
> handled by the driver so the error comes again and
> again
> until the irq-lockup code hits.
> 
> I made some patches to fix this problem but the
> earliest
> version of the patch was for 2.6.13 - if you're
> lucky it
> may apply to your 2.6.12.
> 
> For 2.6.13:
>   
>
http://article.gmane.org/gmane.linux.drivers.dvb/20005/raw
> 
> For 2.6.15:
>   
>
http://article.gmane.org/gmane.linux.drivers.dvb/22947/raw
> 
> For 2.6.16:
>   
>
http://article.gmane.org/gmane.linux.drivers.dvb/24513/raw
> 
> Ciao, ET.
> 




More information about the linux-dvb mailing list