[linux-dvb] Pinnacle 400e USB DVB-S something to try

Andrew de Quincey adq_dvb at lidskialf.net
Wed Nov 22 17:50:35 CET 2006


On Tuesday 21 November 2006 15:52, Andrea Venturi wrote:
> Patrick Boettcher wrote:
> > On Fri, 17 Nov 2006, Andrew de Quincey wrote:
> >>>> that's all as a first report. let me know if you need more info.
> >>>
> >>> This is a problem in the tda10086-module - but I'm unable to see it.
> >>> Andrew, can you take a look, please?
> >>
> >> Hmm, there are several places - I'm assuming the stacktrace is knackered
> >> and is sticking at set_frontend.
> >>
> >> Is this reproducable easily? If so, I can hack a debug patch together...
>
> i'm coming back with more info (i can provide more info about anything):
>
> 1. moved on to a newer 2.6.18 kernel
>
>  andrea at nb-venturi:~$ uname -a
>  Linux nb-venturi 2.6.18 #3 PREEMPT Wed Oct 18 08:33:12 CEST 2006 i686
>  GNU/Linux
>
> 2. still with "nvidia" binary
>
> 3. got the new git tree from ~pb:
>
> http://linuxtv.org/hg/~pb/v4l-dvb?cmd=changeset;node=4f1ca20313e5;style=git
>web
>
> 4. compile & install cleanly
>
> 5. when there's the device hotplug, i can see in dmesg:
>
> usb 5-2.2.3: new high speed USB device using ehci_hcd and address 6
> usb 5-2.2.3: configuration #1 chosen from 1 choice
> dvb-usb: found a 'Pinnacle 400e DVB-S USB2.0' in cold state, will try to
> load a firmware
> dvb-usb: downloading firmware from file 'dvb-usb-pctv-400e-01.fw'
> usbcore: registered new driver dvb_usb_ttusb2
> usb 5-2.2.3: USB disconnect, address 6
> dvb-usb: generic DVB-USB module successfully deinitialized and
> disconnected. usb 5-2.2.3: new high speed USB device using ehci_hcd and
> address 7 usb 5-2.2.3: configuration #1 chosen from 1 choice
> dvb-usb: found a 'Pinnacle 400e DVB-S USB2.0' in warm state.
> dvb-usb: will pass the complete MPEG2 transport stream to the software
> demuxer.
> DVB: registering new adapter (Pinnacle 400e DVB-S USB2.0).
> DVB: registering frontend 0 (Philips TDA10086 DVB-S)...
> dvb-usb: Pinnacle 400e DVB-S USB2.0 successfully initialized and connected.
>
> 6. dump test with dvbstream :
>
> andrea at nb-venturi:~$ dvbstream -f 10847 -p V -o 8192 > /dev/null
> dvbstream v0.6 - (C) Dave Chapman 2001-2004
> Released under the GPL.
> Latest version available from http://www.linuxstb.org/
> Tuning to 10847 Hz
> Using DVB card "Philips TDA10086 DVB-S", freq=10847
> tuning DVB-S to Freq: 1097000, Pol:V Srate=0, 22kHz tone=off, LNB: 0
> Setting only tone OFF and voltage 13V

Your symbol rate is set to 0 - so its not gonna lock anyway. /BUT/ you're 
quite right, this should be detected and not caused an oops - I'll get a 
patch with some sanity checks together. Thanks for the report.



More information about the linux-dvb mailing list