[linux-dvb] ASUSTEK P7131 Dual TV dvb mode?

v+dvb at iki.fi v+dvb at iki.fi
Fri Oct 6 20:33:30 CEST 2006


On Sun, Oct 01, 2006 at 01:01:52AM +0200, you [hermann pitton] wrote:
> 
> To avoid using radio first in order to get the FM/RF input active for
> DVB-T, you could either use the cable-tv antenna input for it or apply
> the patch I previously linked to.
> 
> After that patch the ability to use the cable-tv antenna input for DVB-T
> and the FM/RF antenna input with a dedicated radio antenna at once is
> lost. Also we would have to change gpio for Composite1 and S-Video to
> 0x0200000 to keep the ability to watch/record DVB-T and input from an
> external tuner at once. For somebody with only this single card it is
> really a feature I guess. Comments or other suggestions?

I took the patch from http://www.spinics.net/lists/vfl/msg28220.html and
compiled it. 

Dvb still didn't work after the boot and loading the modules until I used fm
radio first. In dmesg I see

[   53.885183] saa7130/34: v4l2 driver version 0.2.14 loaded
[   53.885471] saa7133[0]: found at 0000:05:02.0, rev: 209, irq: 20, latency: 64, mmio: 0xfe8ff800
[   53.885478] saa7133[0]: subsystem: 1043:4876, board: ASUSTeK P7131 Dual [card=78,insmod option]
[   53.885486] saa7133[0]: board init: gpio is 0
[   53.885492] saa7133[0]: gpio: mode=0x0000000 in=0x0000000 out=0x0000000 [pre-init]
[   54.036374] saa7133[0]: i2c eeprom 00: 43 10 76 48 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[   54.036387] saa7133[0]: i2c eeprom 10: ff ff ff 0f ff 20 ff ff ff ff ff ff ff ff ff ff
[   54.036397] saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 03 08 ff 00 d5 ff ff ff ff
[   54.036403] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   54.036409] saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 55 50 ff ff ff ff ff ff
[   54.036414] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   54.036420] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   54.036425] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[   54.044459] saa7133[0]: gpio: mode=0x0200000 in=0x0000000 out=0x0000000 [Television]
[   54.044549] saa7133[0]: gpio: mode=0x0200000 in=0x0000000 out=0x0000000 [Television]
[   54.148206] tuner 1-004b: chip found @ 0x96 (saa7133[0])
[   54.196139] tuner 1-004b: setting tuner address to 61
[   54.236073] tuner 1-004b: type set to tda8290+75a
[   54.303192] saa7133[0]: registered device video0 [v4l2]
[   54.303349] saa7133[0]: registered device vbi0
[   54.303503] saa7133[0]: registered device radio0
[   54.303576] saa7133[0]: gpio: mode=0x0200000 in=0x0000000 out=0x0000000 [Television]
[   54.356309] DVB: registering new adapter (saa7133[0]).
[   54.356485] DVB: registering frontend 1 (Philips TDA10046H DVB-T)...
[   54.377064] saa7134 ALSA driver for DMA sound loaded
[   54.377214] saa7133[0]/alsa: saa7133[0] at 0xfe8ff800 irq 20 registered as card -1
[   54.377064] saa7134 ALSA driver for DMA sound loaded
[   54.377214] saa7133[0]/alsa: saa7133[0] at 0xfe8ff800 irq 20 registered as card -1
[  262.373167] tda1004x: setting up plls for 48MHz sampling clock
[  262.640762] tda1004x: found firmware revision 29 -- ok
[  278.732418] tda1004x: setting up plls for 48MHz sampling clock
[  279.000015] tda1004x: found firmware revision 29 -- ok
[  297.925255] saa7133[0]: gpio: mode=0x0200000 in=0x0000000 out=0x0200000 [Radio]
[  300.364923] saa7133[0]: dsp access error
[  300.364925] saa7133[0]: dsp access error
[  300.364929] saa7133[0]: dsp access error
[  300.364931] saa7133[0]: dsp access error
[  300.364940] saa7133[0]: gpio: mode=0x0200000 in=0x0000000 out=0x0200000 [Radio]
[  303.148613] tda1004x: setting up plls for 48MHz sampling clock
[  303.416208] tda1004x: found firmware revision 29 -- ok
[  735.499843] PPP BSD Compression module registered
[  735.502874] PPP Deflate Compression module registered
[ 4063.843686] tda1004x: setting up plls for 48MHz sampling clock
[ 4064.111282] tda1004x: found firmware revision 29 -- ok


This not a huge problem as the workaround works. I just thought to let you
know.



-- v -- 

v at iki.fi




More information about the linux-dvb mailing list