[linux-dvb] ASUSTEK P7131 Dual TV dvb mode?

hermann pitton hermann-pitton at arcor.de
Mon Oct 9 01:50:15 CEST 2006


Hi,

Am Sonntag, den 08.10.2006, 16:11 +0300 schrieb v+dvb at iki.fi:
> On Sun, Oct 08, 2006 at 11:08:35AM +0300, you [v+dvb at iki.fi] wrote:
> > 
> > BTW, now I can't get sound from fm radio not analog tv at all:
> > 
> > [140924.232483] saa7133[0]: dsp access error
> > [140924.232487] saa7133[0]: dsp access error
> > 
> > I don't think the saa7134-dvb patch made the difference, as this happens
> > without saa7134-dvb module being loaded. Is that "saa7133[0]/alsa:
> > saa7133[0] at 0xfe8ff800 irq 20 registered as card -1" line crucial?
> 
> After a reboot it went away. Fm and analog tv sound now work.
> 
> No amount of rmmod/modprobe saa7134{,-alsa,-dvb} helped but after a reboot
> the sound worked again.
> 
> It still says 
> [   55.034364] saa7134 ALSA driver for DMA sound loaded
> [   55.034385] saa7133[0]/alsa: saa7133[0] at 0xfe8ff800 irq 20 registered as card -1
> 
> so card = -1 doesn't seem fatal.

it is ok, it just auto enumerates the next available minors for the dsps
and mixers. Use the index=N option to have it specified.

> I seem to recall the sound has gone silent on some past reboots, I really
> can't figure out what the difference, or is it just spurious...

we have only Dual FM (A2) here and you should have BG-NICAM.

Didn't notice anything yet, except audio is delayed for about 2 seconds
also on previously fast tuners (FM1216/I hm) and the tda8290/tda8275a
combo, always much slower anyway, has a short crack after changing a
channel, likely automute timing is too short now.

That is not unusual after such detection changes, timing was always
tricky, but will start some more longish analog recordings next days.

That the gpio triggered antenna switch on DVB-T doesn't work intrigues
me more, but don't have that card variant.

Cheers,
Hermann





More information about the linux-dvb mailing list