[linux-dvb] Trouble with Pinnacle 310i DVB-T

Cabrito Estrabico cabritoestrabico at wanadoo.fr
Fri Oct 13 01:17:51 CEST 2006


Hartmut Hackmann a écrit :
>
>
> Cabrito Estrabico wrote:
>> Hartmut Hackmann a écrit :
>>
>>> Hi,
>>>
>>> Cabrito Estrabico wrote:
>>>
>>>> Hello,
>>>> I'm Ubuntu 6.06 LTS user on kernell 2.6.15-27-k7 with the last 
>>>> v4l-dvb sources compiled to make
>>>> this Pinnacle 310i runing dvb-t with dvb-fe-tda10046.fw firmware.
>>>> Being from France I use the secam videostandard and everything is 
>>>> ok for analogue tv.
>>>>
>>>> Here is  the dmesg  output when probing saa7134 module with secam=l 
>>>> option :
>>>>
>>>> [17179647.088000] saa7130/34: v4l2 driver version 0.2.14 loaded
>>>> [17179647.088000] **** SET: Misaligned resource pointer: f6594902 
>>>> Type 07 Len 0
>>>> [17179647.092000] ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
>>>> [17179647.092000] ACPI: PCI Interrupt 0000:05:07.0[A] -> Link 
>>>> [APC2] -> GSI 17 (level, low) -> IRQ 66
>>>> [17179647.092000] saa7133[0]: found at 0000:05:07.0, rev: 208, irq: 
>>>> 66, latency: 32, mmio: 0xd3000000
>>>> [17179647.092000] saa7133[0]: subsystem: 11bd:002f, board: Pinnacle 
>>>> PCTV 310i [card=101,autodetected]
>>>> [17179647.092000] saa7133[0]: board init: gpio is 600c000
>>>> [17179647.240000] saa7133[0]: i2c eeprom 00: bd 11 2f 00 54 20 1c 
>>>> 00 43 43 a9 1c 55 d2 b2 92
>>>> [17179647.240000] saa7133[0]: i2c eeprom 10: ff e0 60 06 ff 20 ff 
>>>> ff 00 30 8d 2c 1a 07 ff ff
>>>> [17179647.240000] saa7133[0]: i2c eeprom 20: 01 2c 01 02 02 01 04 
>>>> 31 98 ff 00 a6 ff 21 00 c2
>>>> [17179647.240000] saa7133[0]: i2c eeprom 30: 96 10 03 32 15 20 ff 
>>>> ff 0c 22 17 77 03 1c 88 97
>>>> [17179647.240000] saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff 
>>>> ff ff ff ff ff ff ff ff ff
>>>> [17179647.240000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff 
>>>> ff ff ff ff ff ff ff ff ff
>>>> [17179647.240000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff 
>>>> ff ff ff ff ff ff ff ff ff
>>>> [17179647.240000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff 
>>>> ff ff ff ff ff ff ff ff ff
>>>> [17179647.344000] tuner 5-004b: chip found @ 0x96 (saa7133[0])
>>>> [17179647.396000] tuner 5-004b: setting tuner address to 61
>>>> [17179647.436000] tuner 5-004b: type set to tda8290+75a
>>>> [17179647.508000] saa7133[0]: registered device video0 [v4l2]
>>>> [17179647.508000] saa7133[0]: registered device vbi0
>>>> [17179647.508000] saa7133[0]: registered device radio0
>>>> [17179647.548000] saa7134 ALSA driver for DMA sound loaded
>>>> [17179647.548000] saa7133[0]/alsa: saa7133[0] at 0xd3000000 irq 66 
>>>> registered as card -1
>>>>
>>>>
>>>>
>>>> next, modprobe  saa1734-dvb :
>>>>
>>>> [17179811.560000] DVB: registering new adapter (saa7133[0]).
>>>> [17179811.560000] DVB: registering frontend 0 (Philips TDA10046H 
>>>> DVB-T)...
>>>>
>>>> then, scanning tuning data file :
>>>>
>>>> [17179869.076000] tda1004x: setting up plls for 48MHz sampling clock
>>>> [17179869.344000] tda1004x: found firmware revision 20 -- ok
>>>>
>>>> But scan result is :                           ERROR: initial 
>>>> tuning failed
>>>> dumping lists (0 services)
>>>> Done.
>>>>
>>>> and femon give :
>>>>
>>>> using '/dev/dvb/adapter0/frontend0'
>>>> FE: Philips TDA10046H DVB-T (TERRESTRIAL)
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> status 00 | signal 8080 | snr 7f7f | ber 0001fffe | unc 00000000 |
>>>> ..............  ....................  .............  
>>>> .....................  ........................
>>>> ..............  ....................  .............  
>>>> .....................  ........................
>>>> etc etc
>>>>
>>>> I want to add that I've already manage to have dvb-t on my Ubuntu 
>>>> with an other card.
>>>> So, from where come this trouble ; hardware, configuration ?
>>>>
>>>> Thank you for any help you could give.
>>>>
>>>> Cabrito
>>>>
>>> I think the "initial tuning failed" is not a problem. In this 
>>> configuration,
>>> the channel decoder needs some time to settle. This can give you a 
>>> timeout
>>> in the first attempt, the second should be better.
>>> I guess your problem is that your initial config file is not ok:
>>> Some drivers ignore the parameters for FEC, guard interval etc. For the
>>> TDA10046, you need to set them to AUTO to let the chip determine these
>>> automatically. Unfortunately, there are some bad config files floating
>>> around.
>>> The other issue is that in some countries, the transmitters are off the
>>> channel frequency by +/-167kHz. This is the case in Britain, France and
>>> Australia, probalbly others too. In the current implementation, you 
>>> need
>>> to correct this manually.
>>>
>>> Hartmut
>>>
>>>
>> Hi Hartmut,
>>
>> the « other issue »  is the right one :
>> I just had to shift forward by 167  kHz each channel  frequency   in 
>> the tuning data file to make the TDA10046 driver locking channels.
>>
> Thanks for the info! We are talking about France?
>
>> I wanted to notice that thanks to saa7134  ALSA driver, sound is ok 
>> for dvb-t but cable connected from card to pc is needed for analogue tv.
>> It's not a problem indeed.
>>
> This is not fully correct. With DVB-T, sound is decoded and handled in
> Software and directly transferred to the soundcard. The saa7134-alsa
> module is not involved. You can use it to digitally transfer the audio
> data from analog TV to the sound card (without the cable). The big 
> problem
> is that currently only few applications support this, the conversion and
> transfer need to be handled in user space.
> A Minor issue is that the current version of the module does not 
> initialize
> its mixer device, this also needs to be done with an external app. I am
> going to change this too.
>
>> Thank you Harmtmut for sharing your  big experience.
>>
>> Cabrito
>>
> You're welcome
>   Hartmut
>
>
There is no ambiguity, we are talking about France !

Thanks for these interesting details about sound support on this card.

    Cabrito




More information about the linux-dvb mailing list