[linux-dvb] Terratec Cinergy HT PCMCIA

Hartmut.Hackmann at t-online.de Hartmut.Hackmann at t-online.de
Sun Oct 29 01:41:06 CEST 2006


Hi,
-----Original Message-----
Date: Sat, 28 Oct 2006 16:35:42 +0200
Subject: [linux-dvb] Terratec Cinergy HT PCMCIA
From: Mathieu <mt-kor at club-internet.fr>
To: linux-dvb at linuxtv.org

Hello,

I bought a TV card TERRATEC one month ago but I still have some
technical problem to make it working with linux.  After hours of
research on the WEB, I found that this card has a saa7134 chip coupled
with a tuner tda8290+75a for the analog part. The DVB-T part seems to
work using the Philips TDA10046H DVB-T but I was not able to check if it
works or not because Norway does not have Digital TV yet. (it is
coming). So I installed the cvs version of the v4l drivers and
everything seems to work fine excepted the sound. The images are here
(kdetv, mplayer, auxtv, etc...), but it is impossible to have sound even
using sox or the different commands described in the v4l wiki. The
devices are created of course. alsamixer show correctly the tv-card
mixer but it is impossible to hear anything which is frustrating.

No some technical informations : the distribution I am using is an LFS
with glibc-2.5 and kernel 2.6.18.1. the alsa driver is the
alsa-intel8x0. Some technical informations about the card (I obtain them
by looking in the base register of windows)

chip : saa7134
analog tuner tda8290+75a
DVD-T tuner TDA10046H
gpio seems to be the 0x200000 (but impossible to know if I have to put
it high or low yet)

It start to enter an additional entry in the saa code with the
informations I got, but since it is not completely working yet I didn't
send any patches. So if you have any idea where this problem can come
from I would be glad to have those informations. Moreover, what can I
give you coming the win register base which can be usefull for you.

I describe briefly the command I am using to instal the driver

modprobe saa7134 card=94 alsa=2 i2c_scan=1
modprobe saa7134-alsa
modprobe saa7134-dvb (just for testing)

When you use the saa7134-alsa module, you need to set the recording
source in the mixer, either with a mixer application or -after
everything
is loaded - by switching to any other input and back.
I am preparing a patch for this.

Hartmut





More information about the linux-dvb mailing list