[linux-dvb] Twinhan 1025 FC4 kernel 2.6.11

Michael Krufky mkrufky at linuxtv.org
Mon Sep 11 18:02:05 CEST 2006


Cornel van Lingen (PDT) wrote:
> Thanks Michael.
> 
> The reason I need kernel 2.6.11 is for the VIA MPEG acceleration drivers for
> the CN700 board I am using.

Such drivers only exist in an older kernel?  Sounds fishy to me ....

There is a reason why FC4 has stopped receiving kernel updates.  Use FC5
if you want newer stuff.

> Where can I find documentation or assistance for implementing
> "backwards-compat" for kernel 2.6.11?

There is no such documentation.

If someone had the time to spend writing such documentation, they would
instead just extend the backwards compatability themselves.

Why dont you just take a look inside the mercurial tree's changeset
history for compat patches...  This is the best way for you to see how
such things are done.  I warn you -- there are some major core API
changes around the 2.6.10/2.6.11 time that make backwards-compat a real
challenge.

Not to mention the fact that you are using fedora kernels, which lie
about their versions.  Fedora kernels will fail most of the kernel
backwards-compat tests in the v4l-dvb tree -- consider this the ultimate
monkey-wrench for your cause.

If, however, you or someone else manages to fix backwards-compat for
earlier _vanilla_ kernel versions, please feel free to submit the
patches for inclusion -- I would be happy to push such patches into the
master repository.

Good Luck,

Michael Krufky




More information about the linux-dvb mailing list