[linux-dvb] Terratec Cinergy HT PCMCIA

Hartmut Hackmann hartmut.hackmann at t-online.de
Mon Sep 25 00:52:43 CEST 2006


Hi, Elias

Elias Carotti wrote:
> Hello,
> I bought the Terratec Cinergy HT PCMCIA which include both an analog 
> part and
> a DVB-T tuner. It seems none of them is working for me under Linux.
> 
> When I plug the card in I get the following messages:
> 
> PCI: moved device 0000:02:00.0 resource 0 (200) to 64000000
> Linux video capture interface: v2.00
> i2c-core: driver [ir-kbd-i2c] registered
> saa7130/34: v4l2 driver version 0.2.14 loaded
> saa7130/34: snapshot date 2006-07-17
> PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
> ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 20 (level, low) -> IRQ 16
> saa7133[0]: found at 0000:02:00.0, rev: 209, irq: 16, latency: 0, mmio:
> 0x64000000
> PCI: Enabling bus mastering for device 0000:02:00.0
> PCI: Setting latency timer of device 0000:02:00.0 to 64
> saa7133[0]: subsystem: 153b:1172, board: UNKNOWN/GENERIC 
> [card=0,autodetected]
> saa7133[0]: board init: gpio is 0
> i2c_adapter i2c-1: adapter [saa7133[0]] registered
> i2c-dev: adapter [saa7133[0]] registered as minor 1
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x7a, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x47, len=0
> i2c_adapter i2c-1: master_xfer[0] W, addr=0x50, len=1
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x50, len=128
> saa7133[0]: i2c eeprom 00: 3b 15 72 11 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
> saa7133[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 1b 02 51 96 2b
> saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
> saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 22 15 10 fd 79 44 9f c2 8f
> saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x00, len=0
> ....
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x07, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x08, len=0
> saa7133[0]: i2c scan: found device @ 0x10  [???]
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x09, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x0a, len=0
> ......
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x4a, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x4b, len=0
> saa7133[0]: i2c scan: found device @ 0x96  [???]
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x4c, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x4d, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x4e, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x4f, len=0
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x50, len=0
> saa7133[0]: i2c scan: found device @ 0xa0  [eeprom]
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x51, len=0
> saa7133[0]: i2c scan: found device @ 0xa2  [???]
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x52, len=0
> saa7133[0]: i2c scan: found device @ 0xa4  [???]
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x53, len=0
> saa7133[0]: i2c scan: found device @ 0xa6  [???]
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x54, len=0
> .........
> i2c_adapter i2c-1: master_xfer[0] R, addr=0x7f, len=0
> saa7133[0]: registered device video0 [v4l2]
> saa7133[0]: registered device vbi0
> 
> 
> 
> which, apparently, means that the card is recognized as a saa713x and the
> proper driver is loaded. I tried to follow the instructions on the wiki,
> using tvtune and trying different combinations of tuner/card parameters 
> when
> loading the module, but I have been unlucky and, again, none of them worked
> for me.
> 
> For what concerns the DVB part, it seems nothing happens when I load
> saa7134-dvb, neither a device file is created under /dev (I am using udev
> which is working pretty well for what concerns the rest) nor any message
> seems to be logged.
> 
> Does anyboy know how to make this card work under Linux (I am using kernel
> 2.6.17-gentoo-r7)?
> 
There is a good chance that at least the RF sections work if you force
the card type to 94, so:
modprobe saa7134 card=94
modprobe saa7134-dvb
watch carefuly the kernel messages. If you dn't have this card type, you
should upgrade the driver first from http://www.linuxtv.org.

Good luck
   Hartmut



More information about the linux-dvb mailing list