[linux-dvb] Re: [video4linux-cvs] [hg:v4l-dvb] Add support for Opera S1- DVB-USB

Johannes Stezenbach js at linuxtv.org
Fri Apr 20 13:53:08 CEST 2007


On Fri, Apr 20, 2007, Mauro Carvalho Chehab wrote:
> Argh! Too much flood for two simple defines!

I _think_ the point Mike was driving at is that there
is an established coding pattern of having a

struct foo_config {
	u8 i2c_addr;
	...
};

If you use that then the #define is (at least) superflous,
"foo_tuner.i2c_addr = 0x62;" does the job.

If you don't use it, then the #define increases readability.
However, experience shows that soon enough there'll be
another similar device with a different i2c_addr so it makes
sense to use the pattern right from the start.


HTH,
Johannes



More information about the linux-dvb mailing list