[linux-dvb] 2.6.20 with latest hg drivers and dib0700

Chris Murton chris.linuxtv at fruble.co.uk
Sat Apr 21 23:30:53 CEST 2007


Hi Mike,

I trawled back through this list and found a post to it at some point. I 
haven't got the archive URL to hand, but I can mail you the firmware I have?

If it's any consolation, it appears that whilst I have been out today 
it's been up to it's usual tricks - no marked improvement!

Thanks,
Chris

Mike H wrote:
> Hi Chris,
> 
> I have been getting exactly the same problem for a while, disconnects a
> few times a day and it's getting frustrating.
> 
> Where did you get the updated firmware from? I really want to find a
> solution to this!
> 
> Cheers,
> 
> Mike
> 
> On 4/21/2007, "Chris Murton" <chris.linuxtv at fruble.co.uk> wrote:
> 
>> Ignore me, I just saw some of the stuff about file descriptors - so am
>> presuming a mythbackend stop / start will bring the device back.
>>
>> However it could be interesting to see how this firmware fairs against
>> the stock kernel driver support.
>>
>> Chris
>>
>> Chris Murton wrote:
>>> Hi,
>>>
>>> I upgraded to the latest hg drivers against a 2.6.20 kernel for my
>>> Nova-T 500 USB and whilst the Oopses went away, the driver now appears
>>> to disconnect more frequently than it did before - I'm also seeing more
>>> frequent partial locks in MythTV (L_s instead of LMS).
>>>
>>> Apr 21 10:44:46 basil kernel: usb 2-1: USB disconnect, address 2
>>> Apr 21 10:46:44 basil kernel: dvb-usb: could not submit URB no. 0 - get
>>> them all back
>>> Apr 21 10:46:44 basil kernel: dvb-usb: error while enabling fifo.
>>> Apr 21 10:50:10 basil kernel: dvb-usb: error while stopping stream.
>>>
>>> I tried the latest firmware that I could find
>>> (dvb-usb-dib0700-02-rc1.fw) and that gave me similar results with no
>>> noticeable improvement.
>>>
>>> I'm now trying a different approach, using the 2.6.20 kernel drivers
>>> with the latest firmware.. the partial locks have gone away and no
>>> disconnects yet but it's only been running for 30 minutes!
>>>
>>> Also, I don't know if anyone else has had this but when the USB
>>> disconnects occur it does not reconnect, but as soon as I reboot
>>> something must trigger the USB device to come back on as I can see it
>>> being re-probed and brought online as the box is going down - any thoughts?
>>>
>>> Thanks
>>> Chris
>> _______________________________________________
>> linux-dvb mailing list
>> linux-dvb at linuxtv.org
>> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb




More information about the linux-dvb mailing list