[linux-dvb] WinTV Nova-T PCI 500 new issues

Chris Murton chris.linuxtv at fruble.co.uk
Mon Aug 6 22:31:33 CEST 2007


Hi Trent,

Trent Piepho wrote:
> On Mon, 6 Aug 2007, Chris Murton wrote:
>> Trent Piepho wrote:
>>>> DVB: Unable to find symbol mt2060_attach()
>>> That is your problem.  You didn't compile the mt2060 module, or it's not
>>> installed, or your modprobe information is out of date (run depmod), or
>>> your module utils version is too old (need 3.2).
>> Thanks for your pointers, I've just taken a look to check :-
>>
>> basil:~# modinfo mt2060
>> filename:
>> /lib/modules/2.6.21/kernel/drivers/media/dvb/frontends/mt2060.ko
>> author:         Olivier DANET
>> description:    Microtune MT2060 silicon tuner driver
>> license:        GPL
>> vermagic:       2.6.21 mod_unload
>> depends:
>> parm:           debug:Turn on/off debugging (default:off). (int)
>>
>> It modprobes fine, but I don't get anything to say it's seen the tuner
>> in dmesg (which looking at the source code of mt2060.c, I should do) and
>> i still have no luck.
> 
> It won't print anything when you load it.  Did you check your module utils
> version?  Run depmod?
> 
> Check the dates on the mt2060.ko file and the other drivers you are loading,
> like dvb-usb-dib0700.ko and make sure they are the same.  You could be mixing
> old modules and new modules.
> 
>> Should mt2060 be manually probed in at some point in the boot process?
> 
> No.  It should be loaded automatically by the dib0700 driver.

I have checked and double checked, including new source and distcleaning 
and looking in /lib/modules/2.6.21/drivers/media/dvb that all the 
modules are overwritten when I do a make install in the source tree for 
v4l-dvb.

They are, and yet whenever I reboot when these modules are in place, I 
get the error about an unknown symbol for mt2060_attach().

Thanks
Chris



More information about the linux-dvb mailing list