[linux-dvb] wintv 1100 fm radio

Yohann MARTINEAU yohann.martineau at gmail.com
Tue Dec 4 12:17:10 CET 2007


hello,

I'm trying to setup a wintv 1100 card on my computer, I ordered the antenna
but I did not receive it for the moment. But I would like to test my
configuration with FM radio. Is it possible ?

To install my card on my debian etch, I followed the excellent instructions
provided here:
http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-1110

I tried to scan with the dvbscan command, and I have some errors, but I
think it is normal as I did not plug the antenna.
For your information, here is the command and its corresponding output:


$ scan /usr/share/doc/dvb-utils/examples/scan/dvb-t/fr-Brest scanning
/usr/share/doc/dvb-utils/examples/scan/dvb-t/fr-Brest
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 546000000 0 1 9 1 1 0 0
initial transponder 482000000 0 1 9 1 1 0 0
initial transponder 506000000 0 1 9 1 1 0 0
initial transponder 490000000 0 1 9 1 1 0 0
initial transponder 530000000 0 1 9 1 1 0 0
initial transponder 514000000 0 1 9 1 1 0 0
>>> tune to:
546000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_1_2:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to:
546000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_1_2:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE
(tuning failed)
WARNING: >>> tuning failed!!!
[...]
ERROR: initial tuning failed
dumping lists (0 services)
Done.


The installation seems ok, here is a snip of dmseg:

pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Linux video capture interface: v2.00
ACPI: PCI Interrupt 0000:00:1f.3[B] -> GSI 17 (level, low) -> IRQ 114
saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt 0000:0c:02.0[A] -> GSI 18 (level, low) -> IRQ 90
saa7133[0]: found at 0000:0c:02.0, rev: 209, irq: 90, latency: 64, mmio:
0xf3aff800
saa7133[0]: subsystem: 0070:6701, board: Hauppauge WinTV-HVR1110
DVB-T/Hybrid [card=104,autodetected]
saa7133[0]: board init: gpio is 6400000
input: HVR 1110 as /class/input/input4
ir-kbd-i2c: HVR 1110 detected at i2c-1/1-0071/ir0 [saa7133[0]]
saa7133[0]: i2c eeprom 00: 70 00 01 67 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: ff ff ff 0e ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 32 32 01 01 33 88 ff 00 aa ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 60 ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 80: 84 09 00 04 20 77 00 40 da 2a 25 f0 73 05 29 00
saa7133[0]: i2c eeprom 90: 84 08 00 06 cb 05 01 00 94 48 89 72 07 70 73 09
saa7133[0]: i2c eeprom a0: 23 5f 73 0a fc 72 72 0b 2f 72 0e 01 72 0f 03 72
saa7133[0]: i2c eeprom b0: 10 01 72 11 ff 79 15 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom c0: 84 09 00 04 20 77 00 40 da 2a 25 f0 73 05 29 00
saa7133[0]: i2c eeprom d0: 84 08 00 06 cb 05 01 00 94 48 89 72 07 70 73 09
saa7133[0]: i2c eeprom e0: 23 5f 73 0a fc 72 72 0b 2f 72 0e 01 72 0f 03 72
saa7133[0]: i2c eeprom f0: 10 01 72 11 ff 79 15 00 00 00 00 00 00 00 00 00
tveeprom 1-0050: Hauppauge model 67019, rev B4B4, serial# 2435802
tveeprom 1-0050: MAC address is 00-0D-FE-25-2A-DA
tveeprom 1-0050: tuner model is Philips 8275A (idx 114, type 4)
tveeprom 1-0050: TV standards PAL(B/G) NTSC(M) PAL(I) SECAM(L/L')
PAL(D/D1/K) ATSC/DVB Digital (eeprom 0xfc)
tveeprom 1-0050: audio processor is SAA7131 (idx 41)
tveeprom 1-0050: decoder processor is SAA7131 (idx 35)
tveeprom 1-0050: has radio, has IR receiver, has IR transmitter
saa7133[0]: hauppauge eeprom: model=67019
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1b.0 to 64
tuner' 1-004b: chip found @ 0x96 (saa7133[0])
tda8290 1-004b: setting tuner address to 61
tda8290 1-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
DVB: registering new adapter (saa7133[0])
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: trying to boot from eeprom
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: found firmware revision 20 -- ok





Before any test, my FM antenna was already plugged. I tried to listen to the
radio using "radio" package provided with debian repository, and even with
gqradio, but the behavior is the same, I can tune a frequency, but I cannot
here anything.
When I try a scan, it does not find any frequency.

Please let me know if anyone has already done that, even with another card.
Is it absolutely necessary to perform a first scan on dvb channels (with a
plugged antenna) to access FM channels ?

Sorry if my vocabulary is not appropriated, I know nothing about dvb.


Best Regards,

Yohann Martineau
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20071204/b25902af/attachment.htm 


More information about the linux-dvb mailing list