[linux-dvb] patch 1 / 2: fix broken documentation for bt8xx cards

Uwe Bugla uwe.bugla at gmx.de
Sun Feb 4 17:19:37 CET 2007


Hi everybody,
I?ve been sending in this stuff several times now, overworking it two times to involve Mauro Chehab?s critical statements (missing security warnings).
This docu has been broken for months now, and its highest time now to push it into the kernel. I do not want to carry it around with me for another ten months!

Signed-off-by: Uwe Bugla <uwe.bugla at gmx.de>

--- a/Documentation/dvb/bt8xx.txt
+++ b/Documentation/dvb/bt8xx.txt
@@ -9,9 +9,33 @@
 Please see Documentation/dvb/cards.txt => o Cards based on the Conexant Bt8xx PCI bridge:
 
 Compiling kernel please enable:
-a.)"Device drivers" => "Multimedia devices" => "Video For Linux" => "BT848 Video For Linux"
+a.)"Device drivers" => "Multimedia devices" => "Video For Linux" => "Enable Video for Linux API 1 (DEPRECATED)"
-b.)"Device drivers" => "Multimedia devices" => "Digital Video Broadcasting Devices"
- => "DVB for Linux" "DVB Core Support" "Bt8xx based PCI Cards"
+b.)"Device drivers" => "Multimedia devices" => "Video For Linux" => "Video Capture Adapters" => "BT848 Video For Linux"
+c.)"Device drivers" => "Multimedia devices" => "Digital Video Broadcasting Devices" => "DVB for Linux" "DVB Core Support" "Bt8xx based PCI Cards"
+
+Please use the following options with care as deselection of drivers which are in fact necessary
+may result in DVB devices that cannot be tuned due to lack of driver support:
+You can save RAM by deselecting every frontend or DST module that your DVB card does not need.
+
+First please remove the static dependency of DVB card drivers on all frontend modules for all possible card variants by enabling:
+d.) "Device drivers" => "Multimedia devices" => "Digital Video Broadcasting Devices"
+ => "DVB for Linux" "DVB Core Support" "Load and attach frontend modules as needed"
+
+If you know the frontend driver that your card needs please enable:
+e.)"Device drivers" => "Multimedia devices" => "Digital Video Broadcasting Devices"
+ => "DVB for Linux" "DVB Core Support" "Customise DVB Frontends" => "Customise the frontend modules to build"
+ Then please select your card-specific frontend module.
+
+Do you use one of the following cards?
+1. Twinhan DST (FTA and CI) family (DVB-S/C/T/ATSC)
+2. Pinnacle PCTV SAT CI
+3. Chaintech DST-1000
+4. DNTV Live !
+
+If not you can save additional RAM by enabling:
+f.)"Device drivers" => "Multimedia devices" => "Digital Video Broadcasting Devices" => "DVB for Linux" "DVB Core Support"
+ "Bt8xx based PCI Cards" => "Customise DST support" => "Customise DST modules to build"
+ Then please deselect "DST module" and "DST CA module"
 
 2) Loading Modules
 ==================
@@ -68,7 +92,7 @@
 	$ modprobe dvb-bt8xx
 
 For a full list of card ID's please see Documentation/video4linux/CARDLIST.bttv.
-In case of further problems send questions to the mailing list: www.linuxdvb.org.
+In case of further problems please subscribe and send questions to the mailing list: linux-dvb at linuxtv.org.
 
 Authors: Richard Walker,
 	 Jamie Honan,

Best regards

Uwe

-- 
Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer



More information about the linux-dvb mailing list