[linux-dvb] KNC1 DVB-C+, CineView v. 3.0 and Conax CAM: PC card did not respond

Tomas.Linden at Helsinki.FI Tomas.Linden at Helsinki.FI
Wed Feb 21 09:35:31 CET 2007


I have a KNC1 TV-Station DVB-C Plus card
   http://www.knc1.com/img/presse_big/karte_dvb_c_plus.jpg
with a CineView CI-interface version 3.0 instead of the version 1.1 shown here
   http://www.knc1.de/img/presse_big/karte_cineview.jpg
and a Conax 4.00e Rev 1.1 CAM
   http://www.koodinvuoksi.net/catalog/resize.php?image=images/cam_conax.jpg&width=
I'm using Fedora Core 6 with this kernel
   Linux asterix 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 19:28:18 EST 2007
i686 athlon i386 GNU/Linux

Reception of free to air broadcasts work fine. The problem is that the
Conax card is not initialized. Inserting and removing the Conax CAM always 
results in the error message
   dvb_ca adaptor 0: PC card did not respond :(
The Conax card works fine in a Handan DVB-C 5000 box.

modprobe budget_av gives:

saa7146: register extension 'budget_av'.
ACPI: PCI Interrupt 0000:04:08.0[A] -> Link [LNKA] -> GSI 18 (level, low) -> IRQ 21
saa7146: found saa7146 @ mem f8a16400 (revision 1, irq 21) (0x1894,0x0021).
saa7146 (0): dma buffer size 192512
DVB: registering new adapter (KNC1 DVB-C Plus).
adapter failed MAC signature check
encoded MAC from EEPROM was ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff
saa7146_vv: saa7146 (0): registered device video1 [v4l2]
KNC1-0: MAC addr = 00:09:d6:6d:5c:c4
DVB: registering frontend 0 (Philips TDA10021 DVB-C)...
budget-av: ci interface initialised.
budget-av: cam inserted A
dvb_ca adaptor 0: PC card did not respond :(

Output of lspci -vvv:
04:08.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
         Subsystem: KNC One Unknown device 0021
         Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
         Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
         Latency: 64 (3750ns min, 9500ns max)
         Interrupt: pin A routed to IRQ 21
         Region 0: Memory at faaff400 (32-bit, non-prefetchable) [size=512]

tlinden at asterix ~> ls -l /dev/dvb/adapter0/
total 0
crw------- 1 tlinden root 212, 6 Feb 21 10:20 ca0
crw------- 1 tlinden root 212, 4 Feb 21 10:20 demux0
crw------- 1 tlinden root 212, 5 Feb 21 10:20 dvr0
crw------- 1 tlinden root 212, 3 Feb 21 10:20 frontend0
crw------- 1 tlinden root 212, 7 Feb 21 10:20 net0

I have seen other descriptions of similar problems with Conax CAMs, but I
have not yet seen any solution.
   http://www.dvbforum.com/ubbthreads/ubbthreads.php?ubb=showflat&Number=31907&page=21
It seems that the CineView is working well for people who don't have
Conax encryption.

How can one get debugging information from the CI-module, CAM and 
the PC-card to see why the initialization fails?

Is the pcsc-lite package of any use in connection with these kinds of
smart cards?
   http://pcsclite.alioth.debian.org/

Best regards,                        Tomas Lindén


More information about the linux-dvb mailing list