[linux-dvb] cant get channels

Marcel 't Hart marcel at familiethart.nl
Mon Feb 26 23:26:36 CET 2007


Dear All,

I have a KNC one with device number 0022. I used the HG sources and
the patch from E9hack. my fedora box is able to find my device (from
dmesg):
KNC1-0: MAC addr = 00:09:d6:6d:75:5b
DVB: registering frontend 0 (Philips TDA10023 DVB-C)...
budget-av: ci interface initialised.
PCI: Found IRQ 9 for device 0000:02:03.0
PCI: Sharing IRQ 9 with 0000:02:09.0
budget-av: cam inserted A
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
dvb_ca adapter 0: DVB CAM detected and initialised successfully

However lspci still gives unknown device
lspci -v:
2:09.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
        Subsystem: KNC One Unknown device 0022
        Flags: bus master, medium devsel, latency 32, IRQ 9
        Memory at f4000000 (32-bit, non-prefetchable) [size=512]

scandvb will give me this (no succes):
scandvb -A2 -v  nl-caiw
scanning nl-caiw
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 554000000 6900000 0 3
>>> tune to: 554000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_64
>>> tuning status == 0x03
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x03
>>> tuning status == 0x03
>>> tuning status == 0x03
>>> tuning status == 0x00
WARNING: >>> tuning failed!!!
>>> tune to: 554000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_64 (tuning failed)
>>> tuning status == 0x03
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x03
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)
Done.

I cross checked my frequency, thos are ok.

Please help.....

Marcel



More information about the linux-dvb mailing list