[linux-dvb] DVB-T not working on Terratec Cinergy HT PCI

Giorgio Moscardi sukko.ml at sukkology.net
Tue Jan 16 02:08:21 CET 2007


Alle 01:30, martedì 16 gennaio 2007, Giorgio Moscardi ha scritto:
> Sure! Thanks a lot! I'll do that straight tomorrow. I guess I should apply
> it to the mercurial tree, right?
OK, I couldn't resist and tried it right now.
- Installed Mercurial.
- Downloaded linuxtv Mercurial tree.
- Downloaded and applied Michael's patch.
- Compiled and installed new modules.
- Rebooted.

Result: as far as I can guess, Michael's patch only adds automatic recognition 
for my card as type 105:

saa7133[0]: found at 0000:00:09.0, rev: 209, irq: 11, latency: 32, mmio: 
0xfa020
000
saa7133[0]: subsystem: 153b:1175, board: Terratec Cinergy HT PCMCIA 
[card=105,au
todetected]
saa7133[0]: board init: gpio is 0
saa7133[0]: i2c eeprom 00: 3b 15 75 11 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: ff ff ff 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 00 06 ff 00 94 02 51 96 2b
saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
saa7133[0]: i2c eeprom 40: ff 21 00 c0 96 10 03 32 15 10 fd 79 44 9f c2 8f
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 1-004b: chip found @ 0x96 (saa7133[0])
tuner 1-004b: setting tuner address to 60
tuner 1-004b: type set to tda8290+75a
tuner 1-004b: setting tuner address to 60
tuner 1-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0

Firmware upload also succeeds:
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision 29 -- ok

Unfortunately, the problem goes further, as the situation is exactly the same 
as when i forced the 105 card type, which basically means analog TV is ok, 
DVB does not work. Please see my previous mail for details.

UPDATE: OK, I just got back Michael's mail expecting this exact situation :). 
I'll try swapping the tuner init sequencies as suggested. BTW, I'm a 
programmer, so I can make some sensed changes, but I have no knowledge on 
this GPIO stuff.

I'll keep you posted, thanks for the help so far.
-- 
Giorgio
------------ Slackware GNU/Linux 11.0 user -------------
ICQ: 10238408
MSN: sukkopera at hotmail.it
Web: http://www.sukkology.net



More information about the linux-dvb mailing list