[linux-dvb] tzap: error while parsing constellation (syntax error) and no sound with mplayer but with mencoder

Nico Sabbi nicola_sabbi at fastwebnet.it
Sun Jan 21 00:08:09 CET 2007


lynx.abraxas at freenet.de wrote:
> Hallo!
> 
> 
> I get this error if I try to use tzap on my "hama USB 2.0 DVB-T Stick":
> 
> tzap ZDF
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> ERROR: error while parsing constellation (syntax error)
> 
> 
> .tzap/channels.conf was created by:
> 
> scan initial_tuning_data.txt >| .tzap/channels.conf
> 
> with:
> 
> cat initial_tuning_data.txt
> # file automatically generated by w_scan
> # (http://free.pages.at/wirbel4vdr/w_scan/index2.html)
> # T freq bw fec_hi fec_lo mod transmission-mode guard-interval hierarchy
> T 191500000 7MHz AUTO AUTO AUTO AUTO AUTO AUTO
> T 522000000 8MHz AUTO AUTO AUTO AUTO AUTO AUTO
> T 530000000 8MHz AUTO AUTO AUTO AUTO AUTO AUTO
> T 570000000 8MHz AUTO AUTO AUTO AUTO AUTO AUTO
> T 730000000 8MHz AUTO AUTO AUTO AUTO AUTO AUTO
>  
> 
> 
> cat .tzap/channels.conf
> Das Erste:191500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:513:514:32
> arte:191500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:33:34:2
> Phoenix:191500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:49:50:3
> EinsPlus:191500000:INVERSION_AUTO:BANDWIDTH_7_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:97:98:6
> Bayerisches FS:530000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:545:546:34
> BR-alpha:530000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:561:562:35
> BR DVB-H INT:530000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:0:0:49
> BR DVB-H Services :530000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:0:0:50
> SWR Fernsehen:530000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:3601:3602:225
> ZDF:730000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:545:546:514
> 3sat:730000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:561:562:515
> Doku/KiKa:730000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_AUTO:TRANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:593:594:517
> 
> 
> What is wrong with channels.conf? How can I fix it? It's for DVB-T in Regensburg (Germany).
> 
> 
> Also mplayer can display the video but without sound. If I let mencoder encode it there is sound:
> 
> 

try with a larget -tsprobe.
What's in your ~/.mplayer/config and ~/.mplayer/mencoder* ?

-- 
"Without a frontend, mplayer is useless" - someone in mplayer-users



More information about the linux-dvb mailing list