[linux-dvb] DVB-S- and DVB-S2-streams with TT3200

Stefan Lucke stefan at lucke.in-berlin.de
Sun Jul 8 10:09:13 CEST 2007


On Monday 21 May 2007 22:36, laasa wrote:
> Yesterday I have my first DVB-S2-streams with the TT3200.
> 
> Sources
> - Manus snapshot at http://jusst.de/manu/stb0899-v4l-dvb.tar.bz2
> - the szap-sources from http://dev.kewl.org/tmp/hvr4000/szap2.tgz
> 
> 
> Envoirenment
> - TT3200 (SAA7146AH, STB0899 C2L, STB6100, LNBP21 PD, 27000 MHz, board B2S3000 Rev 1.0 TT2006.1)
> 	=> may be that the skystar HD is worked like TT3200 with that patch
> - Tested succesfully with
> 	=> Linux-Kernel 2.6.16-45 (from kernel.org)
> 	=> 2.6.17-chw-8 (MythTV R5D1) and
> 	=> 2.6.21.1 (from kernel.org)
> - 32-bit-CPU (Pentium 4, 2.8 GHz with Hyperthreading) => Have no 64-bit- and no SMP-system!

Thanks for your work.

I tested this with:
- linux 2.6.21-5
- Technisat SkyStar HD
- AMD Athlon(tm) 64 X2 Dual Core Processor 3800+

02:06.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
        Subsystem: Technotrend Systemtechnik GmbH Unknown device 1019
        Flags: bus master, medium devsel, latency 32, IRQ 20
        Memory at feaffc00 (32-bit, non-prefetchable) [size=512]

jarada stefan # lspci -v -n -s 02:06.0
02:06.0 0480: 1131:7146 (rev 01)
        Subsystem: 13c2:1019
        Flags: bus master, medium devsel, latency 32, IRQ 20
        Memory at feaffc00 (32-bit, non-prefetchable) [size=512]

Tuning in general seems to be really slow. Somtimes it takes up to
to one minute for szap2 to get a lock:
zapping to 1 'Pro7HD':
sat 0, frequency = 12722 MHz H, symbolrate 22000000, vpid = 0x00ff, apid = 0x0103 sid = 0x27d8 (fec = -2147483648, mod = 2)
Querying info .. Delivery system=DVB-S2
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
----------------------------------> Using 'STB0899 DVB-S2' DVB-S2
diseqc: sat_no:0 pol_vert:0 hi_band:1 cmd:e0 10 38 f3 wait:0

do_tune: API version=2, delivery system = 2
do_tune: Frequency = 2122000, Srate = 22000000 (DVB-S2)
do_tune: Frequency = 2122000, Srate = 22000000 (SET_PARAMS)


status 1a | signal 05aa | snr 0026 | ber 00000000 | unc fffffffe | FE_HAS_LOCK
status 1a | signal 05aa | snr 0027 | ber 00145855 | unc fffffffe | FE_HAS_LOCK
status 1a | signal 05aa | snr 0026 | ber 0065b9aa | unc fffffffe | FE_HAS_LOCK
status 1a | signal 05aa | snr 0025 | ber 00145855 | unc fffffffe | FE_HAS_LOCK
status 1a | signal 05aa | snr 0026 | ber 00000000 | unc fffffffe | FE_HAS_LOCK

Status 0x1a seems a bit doubtfull:
FE_HAS_SIGNAL and FE_HAS_VITERBI are not set.

In DVB-S mode, I've problems to get a lock with some
transpoders at all: ZDF works with vdr, ARD doesn't .

-- 
Stefan Lucke



More information about the linux-dvb mailing list