[linux-dvb] saa7146 64-bit, new kernels & dvbHG?

Oliver Endriss o.endriss at gmx.de
Fri Jun 1 22:04:58 CEST 2007


Bill Eldridge wrote:
> 
> I'm been trying to get saa7146 errors to go away on an AMD 64-bit Feisty 
> Fawn (7.04)
> release, and have recompiled to 2.6.21.3, plus tried installing the 
> latest HG code for DVB & V4L -
> still can't get rid of the errors. Does anyone have any ideas what can 
> fix this?
> (basically, the video records all choppy with my new skystar card).

skystar? The log below indicates that you have a Nova-CI.

> [mpeg2video @ 0xadc600]concealing 315 DC, 315 AC, 315 MV errors
> [mpeg2video @ 0xadc600]00 motion_type at 13 0
> [mpeg2video @ 0xadc600]00 motion_type at 0 6
> [mpeg2video @ 0xadc600]mb incr damaged
> [mpeg2video @ 0xadc600]00 motion_type at 38 13
> [mpeg2video @ 0xadc600]00 motion_type at 18 19
> [mpeg2video @ 0xadc600]00 motion_type at 21 25
> [mpeg2video @ 0xadc600]ac-tex damaged at 3 26
> [mpeg2video @ 0xadc600]00 motion_type at 18 33
> [mpeg2video @ 0xadc600]concealing 360 DC, 360 AC, 360 MV errors
> [mpeg2video @ 0xadc600]00 motion_type at 32 1
> [mpeg2video @ 0xadc600]ac-tex damaged at 2 13
> [mpeg2video @ 0xadc600]ac-tex damaged at 20 23
> [mpeg2video @ 0xadc600]ac-tex damaged at 15 35

What application did you use to create your recordings?

> uname -a
> Linux voa-v 2.6.21.3 #1 SMP Mon May 28 16:50:19 EEST 2007 x86_64 GNU/Linux
> 
> linuxdvb: v4l-dvb-f715da1617df  (from today)
> 
> dmesg initialization:
> [   32.845576] saa7146: register extension 'budget_ci dvb'.
> [   32.845890] ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
> [   32.845921] saa7146: found saa7146 @ mem ffffc20000022000 (revision 1, irq 17) (0x13c2,0x100f).
> [   32.845928] saa7146 (0): dma buffer size 192512
> [   32.845931] DVB: registering new adapter (TT-Budget/WinTV-NOVA-CI PCI)

Do you have the same problems with a 32 bit kernel, in UP mode?
The drivers are not very well tested on 64 bit machines and with SMP.
:-(

CU
Oliver

P.S.:
I assume that your satellite signal is ok, and you verified that your
hardware is ok.

-- 
--------------------------------------------------------
VDR Remote Plugin 0.3.9 available at
http://www.escape-edv.de/endriss/vdr/
--------------------------------------------------------



More information about the linux-dvb mailing list