[linux-dvb] [v4l-dvb-maintainer] drivers/media/dvb/b2c2/flexcop-dma.c uses PCI DMA API

Mauro Carvalho Chehab mchehab at infradead.org
Fri Jun 8 14:30:20 CEST 2007


Hi Trent,

> Here is a patch that does just option B.  I have a couple other
> patches too.

Tracking the flexcop, I've arrived on a similar patch to yours, but this
approach will duplicate some debug macros. This is somewhat ugly. Since
we need this fix for a late -rc, I think that the better for now is to
use an optional code on Makefile that will add flexcop-dma to
b2c2-flexcop only if flexcop pci support is selected. The end result is
very simple, and will solve the issue.

The final patch is this one:
http://git.kernel.org/?p=linux/kernel/git/mchehab/v4l-dvb.git;a=commitdiff;h=ee9a55464446146acbe12556d6de12cad0ac18c7
 
Cheers,
Mauro




More information about the linux-dvb mailing list