[linux-dvb] dvb-c & CI, but no picture?

David Härdeman david at hardeman.nu
Mon Jun 11 08:41:03 CEST 2007


On Thu, June 7, 2007 12:35, Simon Baxter wrote:
>> > David Härdeman wrote:
>> What is the output from gnutv when you execute it like above?
>>
>> (If I record a stream using gnutv to a file without having working
>> encryption, I get a file which is properly recognised by xine as a MPEG
>> stream but which just produces a black window).
>
> I get a file:
>
> gnutv -channels channels.conf -out stdout ONE > outfile.mpg
> [root at media1 ~]# file outfile.mpg
> outfile.mpg: data
>...
> [root at media1 ~]# mplayer -identify outfile.mpg | less
> Can't open joystick device /dev/input/js0: No such file or directory
> Can't init input joystick
> mplayer: could not connect to socket
> mplayer: No such file or directory
> Failed to open LIRC support.
> You will not be able to use your remote control.
> Compiled with runtime CPU detection.
>...
> Playing outfile.mpg.
> TS file format detected.
> DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -2,
> PROBING UP TO 2000000, PROG: 0
> ID_VIDEO_ID=5011
> ID_VIDEO_ID=5011

Yes, I think that's the expected output if everything but the decryption
stage is working. And unfortunately I'm all out of ideas on what is
missing for your setup to work (as I've said, it works for me without any
extra steps).

Do you know if you need to do something in the CAM menu (e.g. enter a
parental pin or something) to activate the CAM?

-- 
David Härdeman




More information about the linux-dvb mailing list