[linux-dvb] Vivanco 21056/LR306 a.k.a. MSI DVB at Anywhere a.k.a LifeView Hybrid doesn't scan

Werner Braun werner.braun at gmx.de
Sat Jun 16 23:38:56 CEST 2007


>No, it has 4e42:0306. Also these have different tuners for analog and
>DVB. You might wait for a comment from Hartmut.

>> I've browsed through the old MSI threads - is there anything known about 
the 
>> usage of frequency offsets (the 167 trick) in Germany, especially 
>> Berlin-Brandenburg region?

>No, not reported. Your tuner is not oparable this way, the probe failed.
>Either it is still some loadorder/timing problem or the hardware
>changed. You might try to use analog TV first and things like "modprobe
>saa7134-alsa", "modprobe -vr saa7134-dvb" and then load it again.

>Does analog still work?
>You might do a cold boot first, 30 seconds no power connected and then
>try only with card=94.

>Cheers,
>Hermann

Hermann,

thanks for your comments. No, analog doesn't work anymore. Funny thing though: 
I've made a minor kernel update today (the SIDUX guys are cranking out 
kernels every other day), meaning the V4L stuff was reset to kernel default, 
and analog worked as it should. I got the upgrade from HG and no analog 
anymore, so something must have get lost on the way. 

BTW, the patch you suggested did work. Card=94 got autodetected. Here's the 
DMESG output:

saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:02:0e.0, rev: 208, irq: 18, latency: 32, mmio: 
0xdd800000
saa7133[0]: subsystem: 4e42:3306, board: LifeView FlyDVB-T Hybrid Cardbus 
[card=94,insmod option]
saa7133[0]: board init: gpio is 210000
saa7133[0]: i2c eeprom 00: 42 4e 06 33 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 00 62 08 ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 ff 01 ed ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 05 01 01 16 32 15 ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 1-004b: chip found @ 0x96 (saa7133[0])
tuner 1-004b: setting tuner address to 61
tuner 1-004b: type set to tda8290+75a
tuner 1-004b: setting tuner address to 61
tuner 1-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
DVB: registering new adapter (saa7133[0])
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: trying to boot from eeprom
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: found firmware revision 29 -- ok
tda827x_probe_version: could not read from tuner at addr: 0xc2

Apparently it takes several tries to get the firmware loaded, and still no 
tuning possible.

Peter, how did you finally get your MSI to work? Which distro are you using?

Cheers
Werner







More information about the linux-dvb mailing list