[linux-dvb] pinnacle 310i fail on some channels

Hartmut Hackmann hartmut.hackmann at t-online.de
Sat Mar 17 00:30:23 CET 2007


Hi, Kevin

KevinLuX schrieb:
> 
>> Hi, Kevin
>>   
> Hi Harmut
> 
>>> Few weeks ago, i modified the driver to support the LNA on this card.
>>> So can you please try the recent version of the driver? You might
>>> set the option debug=1 for the modules tuner and tda827x.
>>>
>>> Another possible cause is that many drivers ignore the channel
>>> parameters while the tda10046 doesn't. You can set all to auto
>>> except bandwidth.
>>>
>>> Best regards
>>>    Hartmut
> i've installed new driver from mercurial this morning.
> Then loaded modules tuner and tda827x with debug=1.
> On modules loading this is kernel output
> 
> tuner 2-004b: chip at addr 4b is a tda8290
> tuner 2-004b: Setting mode_mask to 0x0e
> tuner 2-004b: chip found @ 0x96 (saa7133[0])
> tuner 2-004b: Calling set_type_addr for type=54, addr=0xff, mode=0x04,
> config=0x01
> tuner 2-004b: set addr for type -1
> tuner 2-004b: defining GPIO callback
> tuner 2-004b: tuner 0x4b: called during i2c_client register by adapter's
> attach_inform
> tuner 2-004b: defining GPIO callback
> tuner 2-004b: setting tuner address to 61
> tuner 2-004b: type set to tda8290+75a
> tuner 2-004b: saa7133[0] tuner I2C addr 0x96 with type 54 used for 0x0e
> tda827x: tda827x_attach:
> tda827x: tda827xa tuner found
> DVB: registering new adapter (saa7133[0]).
> DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
> 
> Later as you said i've try to scan on differnt settings particulary
> 
> T 482000000 8MHz AUTO AUTO AUTO AUTO AUTO NONE
> T 506000000 8MHz AUTO AUTO AUTO AUTO AUTO NONE
> 
> During scan kernel output is :
> 
> tda1004x: setting up plls for 48MHz sampling clock
> tda1004x: found firmware revision 20 -- ok
> tda827x: tda8275a AGC2 gain is: 10
> tda827x: tda8275a AGC2 gain is: 10
> tda827x: tda8275a AGC2 gain is: 10  ......
> 
> and this last message is continuely repeated during scan
> 
> Result is :
> Filter timoet for frequency 506 and channels from 482 ( and other
> frequencies)
> 
> With w_scan, i'm also able to see many others channels unfortunately
> xine give me a message :
> input_dvb: ERROR: Trying to get lock...
> 
> kaffeine with its scan, show me only few channels (20 on 70), probably
> because it find during scan more noise than good quality signal on some
> channel
> and unfortunately i can't use channels.conf from scan because it's not
> compatible with kaff.
> 
> Thanks
> Best Regards
> 
You log shows me 2 things:
- you seem to have a very low antenna energy (or there is something
  wrong with my LNA handler. I don't have such a card, so i can't test)
- You should download the firmware from Lifeview. It is more recent (2.9)
  and locks better on bad signals.
In my personal repository http://linuxtv.org/hg/~hhackmann/v4l-dvb
there is a bug fix which might affect your card as well. I originally
considered it minor but this seems not to be the case.

Can you please check this before we continue?

Hartmut



More information about the linux-dvb mailing list