[linux-dvb] KNC1 DVB-C Plus CI/CAM not working

Rutger ter Borg rutger at terborg.net
Sat Nov 3 17:10:39 CET 2007


Dear Linux DVB developers,

Last week I've purchased a KNC One TV-Station DVB-C Plus, including a
CineView and Alphacrypt CAM module. Unfortunately, I haven't been able to
get the decryption working. I've searched this list (and Google) for
solutions, have found similar reports, however none of the proposed fixes
helped.

I have tried combinations of the following:
* (debian-) kernels 2.6.22-2, and 2.6.23-1 (latest)
* different PCI slots (to change the assigned IRQ)
* refitting the cable

The following was successful:
* Tuning to channels using czap

The following doesn't work:
* Enabling the CAM

The system keeps looping over inserted/ejected messages if the CAM is
inserted:

Nov  3 16:06:04 fraggle kernel: ACPI: PCI interrupt for device 0000:00:08.0
disabled
Nov  3 16:13:56 fraggle kernel: Linux video capture interface: v2.00
Nov  3 16:13:56 fraggle kernel: saa7146: register extension 'budget_av'.
Nov  3 16:13:56 fraggle kernel: ACPI: PCI Interrupt 0000:00:08.0[A] -> GSI
19 (level, low) -> IRQ 19
Nov  3 16:13:56 fraggle kernel: saa7146: found saa7146 @ mem
ffffc200001fce00 (revision 1, irq 19) (0x1894,0x0023).
Nov  3 16:13:56 fraggle kernel: saa7146 (0): dma buffer size 192512
Nov  3 16:13:56 fraggle kernel: DVB: registering new adapter (KNC1 DVB-C
Plus MK3)
Nov  3 16:13:56 fraggle kernel: adapter failed MAC signature check
Nov  3 16:13:56 fraggle kernel: encoded MAC from EEPROM was
ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff
Nov  3 16:13:56 fraggle kernel: saa7146_vv: saa7146 (0): registered device
video0 [v4l2]
Nov  3 16:13:56 fraggle kernel: KNC1-0: MAC addr = 00:09:d6:6d:88:7b
Nov  3 16:13:56 fraggle kernel: DVB: registering frontend 0 (Philips
TDA10023 DVB-C)...
Nov  3 16:13:56 fraggle kernel: budget-av: ci interface initialised.
Nov  3 16:13:56 fraggle kernel: budget-av: cam inserted A
Nov  3 16:13:56 fraggle kernel: budget-av: cam ejected 5
Nov  3 16:14:00 fraggle kernel: budget-av: cam inserted A
Nov  3 16:14:00 fraggle kernel: budget-av: cam ejected 5
...
Nov  3 16:14:04 fraggle kernel: budget-av: cam inserted A
Nov  3 16:14:05 fraggle kernel: budget-av: cam ejected 5

, and this inserted/ejected loop keeps repeating. The messages stop when the
CAM is removed from the CI module. The system runs in 64 bit mode on an
AMD64.

Given this,
* Is it more likely to be a driver problem, or a hardware problem? If it is
a driver problem, in which source file should I start looking?
* What cross-checks could I do next to determine the exact problem?

Thanks in advance,
kind regards,

Rutger ter Borg 




More information about the linux-dvb mailing list