[linux-dvb] hvr1300

michael melchert mmelchert03 at yahoo.com
Sun Nov 18 11:22:32 CET 2007


hello all,
got myself a hvr1300 the other day and struggle to make it work.
Initially went with the driver modules included in 2.6.23 kernel and
the cx88 modules were loading properly, no odd messages.
nevertheless, dvbscan doesnt return any station at all. Now, this
maybe due to poor reception at my place (using an indoor aerial
at the moment, need to pick up an extension cable for the outdoor 
one) but it still puzzles me. I am still suspecting that the tuner is not
working - any way to check that?
Next step was to download the last repository from the linuxtv site.
Building the whole bunch and installing it lead to the following messages
in the kernel log:

Linux video capture interface: v2.00
cx88/0: cx2388x v4l2 driver version 0.0.6 loaded
ACPI: PCI Interrupt 0000:02:07.0[A] -> GSI 26 (level, low) -> IRQ 26
cx88[0]: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56,auto
detected]
cx88[0]: TV tuner type 63, Radio tuner type -1
cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.6 loaded
cx2388x alsa driver version 0.0.6 loaded
tveeprom 2-0050: Encountered bad packet header [07]. Corrupt or not a Hauppauge eeprom.
cx88[0]: warning: unknown hauppauge model #0
cx88[0]: hauppauge eeprom: model=0
cx88[0]/0: found at 0000:02:07.0, rev: 5, irq: 26, latency: 64, mmio: 0xfb000000
tuner' 2-0043: chip found @ 0x86 (cx88[0])
tda9887 2-0043: tda988[5/6/7] found @ 0x43 (tuner')
tuner' 2-0061: chip found @ 0xc2 (cx88[0])
tuner-simple 2-0061: type set to 0 (Temic PAL (4002 FH5))
tuner' 2-0063: chip found @ 0xc6 (cx88[0])
wm8775' 2-001b: chip found @ 0x36 (cx88[0])
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
ACPI: PCI Interrupt 0000:02:07.1[A] -> GSI 26 (level, low) -> IRQ 26
cx88[0]/1: CX88x/0: ALSA support for cx2388x boards
cx88[0]/2: cx2388x 8802 Driver Manager
ACPI: PCI Interrupt 0000:02:07.2[A] -> GSI 26 (level, low) -> IRQ 26
cx88[0]/2: found at 0000:02:07.2, rev: 5, irq: 26, latency: 64, mmio: 0xfd000000
cx88/2: cx2388x dvb driver version 0.0.6 loaded
cx88/2: registering cx8802 driver, type: dvb access: shared
cx88[0]/2: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56]
cx88[0]/2: cx2388x based DVB/ATSC card
tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)
DVB: registering new adapter (cx88[0])
DVB: registering frontend 0 (Conexant CX22702 DVB-T)...
cx2388x blackbird driver version 0.0.6 loaded
cx88/2: registering cx8802 driver, type: blackbird access: shared
cx88[0]/2: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56]
cx88[0]/2: cx23416 based mpeg encoder (blackbird reference design)
cx88[0]/2: registered device video1 [mpeg]


Ok, the latest code seems to have some problems handling the eeprom content,
which didnt happen with the 2.6.23 code.
Any comment, pointer would be appreciated.


Michael



 



      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20071118/44cfc5e3/attachment.html 


More information about the linux-dvb mailing list