[linux-dvb] saa7146 vpeirq

Oliver Endriss o.endriss at gmx.de
Mon Nov 26 03:25:39 CET 2007


Simeon Walker wrote:
> Hi,
> 
> Since upgrading to Ubuntu Gutsy (kernel 2.6.22) I see a lot of these
> messages and the stream is badly corrupted:
> 
> saa7146 (0) vpeirq: used 2 times >80%% of buffer (61476 bytes now)

Basically this message means that the interrupt handler is executed very
late. As a workaround you might try to increase the DMA buffer size
('bufsize' module parameter of budget-core).

> The card is an old Win TV Nova-T.
> 
> Reverting to 2.6.20 is ok but I would like to be able to use the
> latest dvb-usb drivers for another card. I tried yesterdays v4l-dvb
> checkout which showed the same problems.

Hm - did you test the checkout with the 2.6.20 kernel?
(Just to find out whether it is the driver's fault or the kernel's.)

CU
Oliver

-- 
----------------------------------------------------------------
VDR Remote Plugin 0.4.0: http://www.escape-edv.de/endriss/vdr/
----------------------------------------------------------------



More information about the linux-dvb mailing list