[linux-dvb] RE : Hauppauge Nova-T Stick (and TD)

Walsh Rod (Nokia-NRC/Tampere) Rod.Walsh at nokia.com
Fri Oct 5 12:42:59 CEST 2007


Hi Thierry

Thanks for the advice - I got there (well at least scan works now).

There was one extra problem not documented on either...
http://linuxtv.org/wiki/index.php/How_to_install_DVB_device_drivers
...or...
e.g. http://www.mythtv.org/wiki/index.php/Hauppauge_WinTV_Nova-T_500_PCI
<http://www.mythtv.org/wiki/index.php/Hauppauge_WinTV_Nova-T_500_PCI>

The "make" didn't work (this is for an Ubuntu 7.04 desktop, all basic
updates and a few things extra, but "nearly new"). Problem was that
/lib/modules/2.6.20-16-generic/source didn't exist. So making that ( i.e.
"source" in that directory) a symlink to
/usr/src/linux-headers-2.6.20-16-generic/ was enough and "make" went about
its jolly business. (Also installed kernel-package in the process but I'm
not sure if it effected anything). I'm guessing this is an Ubuntu specific
issue? 


Any idea when this build and firmware are going to come in the kernel
ready-to-go?


I tested it out with scan, mplayer etc and all went well. MythTV is a bit
funky (couldn¹t get it to just take in the channel.conf file and it gets
worse signal strength and BER than bash-shell ­ bizarre :)

Cheers, Rod.



On 10/3/07 3:04 PM, "ext Thierry Lelegard" <thierry.lelegard at tv-numeric.com>
wrote:

> Have a look at:
> http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-NOVA-T-Stick
>  
> Get the latest dvb drivers to replace those of your kernel:
> http://www.linuxtv.org/wiki/index.php/How_to_install_DVB_device_drivers
> This is as simple as:
> hg clone http://linuxtv.org/hg/v4l-dvb
>  <http://linuxtv.org/hg/v4l-dvbcd>
> cd v4l-dvb
> make
> sudo make install
> after installing mercurial (depends on your distro).
>  
> Get firmware
> http://www.wi-bw.tfh-wildau.de/~pboettch/home/linux-dvb-firmware/dvb-usb-dib07
> 00-1.10.fw 
> <http://www.wi-bw.tfh-wildau.de/~pboettch/home/linux-dvb-firmware/dvb-usb-dib0
> 700-1.10.fw> 
> and rename it as /lib/firmware/dvb-usb-dib0700-03-pre1.fw
>  
> That's it
> -Thierry
>>  
>>  
>> -----Message d'origine-----
>> De :  linux-dvb-bounces at linuxtv.org [mailto:linux-dvb-bounces at linuxtv.org] De
>> la  part de Walsh Rod (Nokia-NRC/Tampere)
>> Envoyé : mercredi 3  octobre 2007 11:36
>> À :  linux-dvb at linuxtv.org
>> Objet : [linux-dvb] Hauppauge Nova-T  Stick (and TD)
>> 
>> Hi  All
>> 
>> Any idea if either the Nova-T Stick or the Nova-TD stick will work  and what
>> I should do to get them up?
>> http://www.hauppauge.co.uk/pages/products/data_novatstick.html
>> http://www.hauppauge.co.uk/pages/products/data_novatdstick.html
>> 
>> They  don¹t ³just work² and I wasn¹t able to find any answers from the
>> linuxtv.org  or mythtv (inc. the archive for this list until Oct¹07)
>> 
>> I¹m aiming at  Unbunt7.04.
>> 
>> ³lsusb² shows the sticks are enumerated ok.  ³grep -i dvb /var/log/messages²
>> says there  might be something amiss...
>> Oct  3 10:12:24 ubuntu-desktop kernel: [    15.621558] dvb-usb: found a
>> 'Hauppauge Nova-T Stick' in cold  state, will try to load a firmware
>> Oct  3 10:12:24 ubuntu-desktop  kernel: [   15.661711] usbcore: registered
>> new interface driver  dvb_usb_dib0700
>> Oct  3 11:00:44 ubuntu-desktop kernel: [    15.636419] dvb-usb: found a
>> 'Hauppauge Nova-T Stick' in cold  state, will try to load a firmware
>> Oct  3 11:00:44 ubuntu-desktop  kernel: [   15.678397] usbcore: registered
>> new interface driver  dvb_usb_dib0700
>> Oct  3 12:10:17 ubuntu-desktop kernel: [    15.693031] dvb-usb: found a
>> 'Hauppauge Nova-T Stick' in cold  state, will try to load a firmware
>> Oct  3 12:10:17 ubuntu-desktop  kernel: [   15.728283] usbcore: registered
>> new interface driver  dvb_usb_dib0700
>> 
>> Also ³scan  /usr/share/doc/dvb-utils/examples/scan/dvb-t/fi-Tampere >
>> /root/.tzap/channels.conf²...
>> ...according to ³http://parker1.co.uk/mythtv_dvb.php  further² implies it
>> just ain¹t working...
>> scanning  /usr/share/doc/dvb-utils/examples/scan/dvb-t/fi-Tampere
>> using  '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
>> main:2247:  FATAL: failed to open '/dev/dvb/adapter0/frontend0': 2 No such
>> file or  directory
>> 
>> I don¹t fear a bit of hard work, but naturally any clues the  above gives to
>> a quick solution would be ever so nice.
>> 
>> Thanks in  advance,
>> Rod.
> 
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20071005/ae5a9dc0/attachment.htm 


More information about the linux-dvb mailing list