[linux-dvb] Asus Tiger can't find any channels

Anssi Purola anssi.purola at gmail.com
Mon Oct 8 11:07:37 CEST 2007


Hi.

(sorry about bad English, if you don't understand something I'm
telling, just ask ;)

I have a Asus Tiger DVB-T card (got it when I bought this used
computer..). lspci says "Philips Semiconductors SAA7133/SAA7135 Video
Broadcast Decoder (rev d1)" and if I don't give any modprobe options,
my system recognices it (dmesg: saa7133[0]: subsystem: 1043:4857,
board: ASUSTeK P7131 Dual [card=78,autodetected]).

But I just can't get it to actually work. I mostly try to scan the
channels with Kaffeine. I've tried different card=xx tuner=xx
compinations etc. And I have also tried to change tuner_config values
in my saa7134-cards.c and caa7134-dvb.c (I downloaded the latest
sources).

Right now Kaffeine shows 45% signal, but it doesn't start to scan the
channels (the status indicator just says 0% and terminal says
"Invalid section length or timeout: pid=17 Invalid section length or
timeout: pid=0". Sometime I had quite good signal (60-70%) and
scanning did work, but Kaffeine still couldn't find any channels. And
sometimes Kaffeine shows signal only when it scans the first line from
my source file.

I have tried scan/tzap also, but they don't find anything.

dmesg |grep -i saa7 :

saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:02:05.0, rev: 209, irq: 22, latency: 32,
mmio: 0xf6006000
saa7133[0]: subsystem: 1043:4857, board: ASUSTeK P7131 Dual
[card=78,autodetected]
saa7133[0]: board init: gpio is 0
input: saa7134 IR (ASUSTeK P7131 Dual) as /class/input/input7
saa7133[0]: i2c eeprom 00: 43 10 57 48 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: ff ff ff 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 03 08 ff 00 b6 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 00 ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c scan: found device @ 0x10  [???]
saa7133[0]: i2c scan: found device @ 0x96  [???]
saa7133[0]: i2c scan: found device @ 0xa0  [eeprom]
tuner 1-004b: chip found @ 0x96 (saa7133[0])
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
DVB: registering new adapter (saa7133[0]).

dmesg |grep -i firmw (don't know what's with the ten line..) :

tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok
tda1004x: found firmware revision 20 -- ok


fi-Alajarvi (the source file):

T 642000000 8MHz 2/3 NONE QAM64 8k 1/8 NONE
T 730000000 8MHz 2/3 NONE QAM64 8k 1/8 NONE
T 578000000 8MHz 2/3 NONE QAM64 8k 1/8 NONE

scan fi-Alajarvi:

scanning fi-Alajarvi
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 642000000 0 2 9 3 1 2 0
initial transponder 730000000 0 2 9 3 1 2 0
initial transponder 578000000 0 2 9 3 1 2 0
>>> tune to: 642000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: filter timeout pid 0x0011
WARNING: filter timeout pid 0x0000
WARNING: filter timeout pid 0x0010
>>> tune to: 730000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to: 730000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
(tuning failed)
WARNING: >>> tuning failed!!!
>>> tune to: 578000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to: 578000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
(tuning failed)
WARNING: >>> tuning failed!!!
dumping lists (0 services)
Done.



More information about the linux-dvb mailing list