[linux-dvb] Pinnacle PCTV Sat HDTV Pro USB (PCTV452e)

garlicdevel at ntlworld.com garlicdevel at ntlworld.com
Mon Oct 29 00:13:20 CET 2007


> 
> From: Daniel Golle <daniel.golle at gmail.com>
> Date: 2007/10/28 Sun PM 09:36:53 GMT
> To: linux-dvb at linuxtv.org
> Subject: Re: [linux-dvb] Pinnacle PCTV Sat HDTV Pro USB (PCTV452e)
> 
> sorry, posted with a wrong subject before... (shame on me)
> On Sun, 28 Oct 2007 17:24:55 +0000, garlicdevel at ntlworld.com wrote:
> > > Thanks! 
> > > That was the missing piece of the puzzle! By using szap2 I can tune
> > in
> > > and receive all DVB-S channels FTA on 19.2E, 
> > > cat dvr0 | mplayer 
> > > works almost perfectly; got some glitches from time to time, but
> > that
> > > was just the same with the ttpci (with budget patch) I used before.
> > > 
> > > -Daniel
> > 
> > wow you've managed to get this working?
> > can you list which driver your using, and which version of stb0899
> > I'm still trying to get video output from mine 
> I use:
> - Linux 2.6.22-ck1 on VIA Esther processor 1200MHz
> - stb0899 from http://linuxtv.org/hg/~manu/stb0899/ (last change on
> 10-10-2007)
> - enable_pctv452e_20071021.patch posted by Dominik Kuhlen
> - I changed the initial value of register STB0899_I2CRPT to 0x58 as
> suggested by Dominik some hours after publishing the patch.
> - szap2 from http://dev.kewl.org/hvr4000/utils/szap2.tgz finally did the
> trick... (again, big thanks to Dominik for this hint!)
> 
> szap2 -r -c /home/daniel/channels.conf -i
> tunes successfully to every DVB-S (but not -S2!) channel I ask it for.
> I can play the stream in /dev/dvb/adapter0/dvr0 with mplayer (actually,
> I do this on my router machine, the box the pinnacle is connected to:
> cat /dev/dvb/adapter0/dvr0 | nc -l -p 12345
> and this on my workstation:
> nc 192.168.XXX.XXX 12345 | mplayer -stop-xscreensaver -v -vo xv -vf
> tfields -
> ).
> 
> got to restart netcat and mplayer everytime I tune to a different
> channel. I guess, this is more a problem with mplayer not expecting the
> TS to end/die unexpectedly...
> 
> Also, I tried to compile szap2 using the headers included in manu's
> stb0899 code instead of the ones included in szap2, which did NOT work
> (tuner doesn't lock to channel).
> 
> Anyway, just to mention, the LED seems to stay yellow at all times after
> plugging the device, but i don't care as i cannot see it anyway ;)
> 
> btw: as dvbscan doesn't work yet with the new tuner api, I need an
> up-to-date channels.conf for 19.2E. somebody, please run dvbscan 
> and send me the result by email.
> 
> -Daniel

thanks for the info this could save me a lot of time
I've tried the above out but I'm still getting no output from dvr0

at this point I'm not sure if it's because I'm using an amd64 system (perhaps non friendly 64bit code somewhere) or if the channel I'm trying to tune to is wrong in channels.conf

can you let me know the channel details you've used to tune on Astra 19.2E (the line used in channels.conf)
this way I can re-align the dish motor using an external decoder box then give it another go

-----------------------------------------
Email sent from www.virginmedia.com/email
Virus-checked using McAfee(R) Software and scanned for spam




More information about the linux-dvb mailing list