[linux-dvb] cx88-dvb: fix nxt200x rf input switching broke my tuner? :)

Nathan Faust nfaust at merchantwarehouse.com
Wed Sep 5 20:01:39 CEST 2007


CityK,

Thanks for your reply, but that is not what I'm seeing in MythTV and
TVTime for /dev/video0.  I'm getting signal from /dev/video0 when I use
the upper input, not the lower one.  I haven't trying tuning 8VSB, but
as for the QAM input, that seems to be working as expected.

Maybe I should look at the driver config for input select in SAA7134 or
swap the input selection lines for VSB and QAM in the dvb code?

After looking at the input selection code in nxt200x.c, QAM and VSB, it
looks like if I switch these lines it will swap the inputs.
	//QAM
-	state->config->set_pll_input(buf+1, 1); 
+	state->config->set_pll_input(buf+1, 0);

	//VSB
-	state->config->set_pll_input(buf+1, 0);
+	state->config->set_pll_input(buf+1, 1);

Am I correct?

I am confused as to what these lines do
	if (state->config->set_ts_params)
		state->config->set_ts_params(fe, 1);  <-- what the
front-end parameter 0 or 1 mean.

Thank you,
Nathan.
-----Original Message-----
From: CityK [mailto:CityK at rogers.com] 
Sent: Wednesday, September 05, 2007 1:33 PM
To: Nathan Faust
Cc: linux-dvb at linuxtv.org
Subject: Re: [linux-dvb] cx88-dvb: fix nxt200x rf input switching broke
my tuner? :)

Nathan Faust wrote:
> Hi,
>
> I've notice the same thing with my Kworld ATSC-110.  
> I'm running Ubuntu 7.10, 2.6.22-10-generic, x86_64.  I guess it is a 
> change in the 2.6.22 kernel.
> Is there anyway to change this back so that QAM and NTSC inputs are 
> the same?
>   

They should be the same now -- that was what the change was all about.

By default now, the top RF input should be 8VSB and the bottom should be
QAM & analog (both ota and cable).







More information about the linux-dvb mailing list