[linux-dvb] Asys P7131 Hybrid: DVB out of range

hermann pitton hermann-pitton at arcor.de
Thu Sep 6 00:32:49 CEST 2007


Hi Paolo,

Am Mittwoch, den 05.09.2007, 13:29 +0200 schrieb Paolo Dell'Aquila:
> This morning I upgraded the kernel of my linux box.
> After that I cloned v4l-dvb and compiled everything. I've done it
> because couldn't watch digital tv with mplayer but only with
> kaffeine.
> Mplayer error was:
> vb_streaming_read, attempt N. 6 failed with errno 0 when reading ...

no such issues here.

> So I tried to update bit I didn't solve the problem.
> 
> 
> Than  I've done some test with Mythtv and auto-scanning
> for channels... and now...
> 
> ...now I'm having the following (BIG) problem:
> dvb-t doesn't work anymore (also in kaffeiene or tzap).
> 
> dmesg has the following error:
> DVB: frontend 0 frequency 2147483647 out of range (51000000..858000000)

That sounds really mad, especially as you are in freq. limits of the
tda8275 and not of the tda8275a, which for sure you have.

> After this mess up, analogical TV is no more properly working, before 
> was really perfect.
> 
> Going crazy...
> 
> 
> thank you for your help.
> 
> 
> P.S.
> I would like to know is some of you could use a patch cable between 
> P7131 and motherboard for listen TV. I've tried sever time but no sound 
> at all and I have to use sox or aplay.

Yes, I do this without any problems, but on the prior P7131 Dual without
LNA. From the bottom, left is left and right is right and the two pins
in the middle are ground.

> 
> Some information about my system:
> SO: Ubuntu 7.07 - Linux linux 2.6.20-16-generic
> 
> dmesg:
> [...]
> [   18.020064] saa7130/34: v4l2 driver version 0.2.14 loaded
> [   18.020132] ACPI: PCI Interrupt 0000:01:09.0[A] -> GSI 17 (level, 
> low) -> IRQ 17
> [   18.020144] saa7133[0]: found at 0000:01:09.0, rev: 209, irq: 17, 
> latency: 64, mmio: 0xcdcff800
> [   18.020152] saa7133[0]: subsystem: 1043:4876, board: ASUSTeK P7131 
> Hybrid [card=112,autodetected]
> [   18.020163] saa7133[0]: board init: gpio is 200000

OK, you are using the patch to change the digital antenna input, no
analog used after latest module unload and the IR receiver is not
plugged.

> [   18.020239] input: saa7134 IR (ASUSTeK P7131 Hybri as /class/input/input4
> [   18.054492] intel_rng: FWH not detected
> [   18.148302] nvidia: module license 'NVIDIA' taints kernel.
> [   18.155554] saa7133[0]: i2c eeprom 00: 43 10 76 48 54 20 1c 00 43 43 
> a9 1c 55 d2 b2 92
> [   18.155568] saa7133[0]: i2c eeprom 10: ff ff ff 0f ff 20 ff ff ff ff 
> ff ff ff ff ff ff
> [   18.155581] saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 03 08 ff 
> 00 d5 ff ff ff ff
> [   18.155593] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff 
> ff ff ff ff ff ff
> [   18.155605] saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 55 50 
> ff ff ff ff ff ff
> [   18.155617] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff 
> ff ff ff ff ff ff
> [   18.155630] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff 
> ff ff ff ff ff ff
> [   18.155642] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff 
> ff ff ff ff ff ff
> [   18.562616] tuner 0-004b: chip found @ 0x96 (saa7133[0])
> [   18.610496] tda8290 0-004b: setting tuner address to 61
> [   18.611021] NET: Registered protocol family 17
> [   18.714276] tuner 0-004b: type set to tda8290+75a
> [   18.762213] tda8290 0-004b: setting tuner address to 61
> [   18.866006] tuner 0-004b: type set to tda8290+75a

Analog detects the right tuner type here.

> [   18.873190] saa7133[0]: registered device video0 [v4l2]
> [   18.873229] saa7133[0]: registered device vbi0
> [   18.873256] saa7133[0]: registered device radio0
> [   18.873732] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, 
> low) -> IRQ 16
> [   18.873766] PCI: Setting latency timer of device 0000:00:1b.0 to 64
> [   18.911272] saa7134 ALSA driver for DMA sound loaded
> [   18.911615] saa7133[0]/alsa: saa7133[0] at 0xcdcff800 irq 17 
> registered as card -2
> [   19.051812] DVB: registering new adapter (saa7133[0])
> [   19.051821] DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
> [   19.121478] tda1004x: setting up plls for 48MHz sampling clock
> [   19.141824] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 16 (level, 
> low) -> IRQ 16
> [   19.141839] PCI: Setting latency timer of device 0000:05:00.0 to 64
> [   19.141970] NVRM: loading NVIDIA UNIX x86 Kernel Module  1.0-9755 
> Mon Feb 26 23:21:15 PST 2007
> [   19.404784] tda1004x: found firmware revision 29 -- ok
> [...]
> [   49.092508] tda1004x: setting up plls for 48MHz sampling clock
> [   49.455718] tda1004x: found firmware revision 29 -- ok
> [   49.796042] DVB: frontend 0 frequency 2147483647 out of range 
> (51000000..858000000)
> [   49.834811] DVB: frontend 0 frequency 2147483647 out of range 
> (51000000..858000000)

For Michael, I'm running latest with all his patches from 20070902 on
two different machines down to 2.6.20, except other analog stuff, the
tda8275a Asus P7131 Dual and a md7134 with FMD1216ME (the triple, but
don't get the second PCI bridge in an analog orange colored MSI
slot ...) and all is fine, means no new issues.

Make sure all old modules are unloaded, the tda827x needs extra care.
Better do a cold reboot in current state! If you have touched the
antenna connectors, the low profile cards come easily to much out of the
slot and cause trouble, check for a good seat when without power.

Try again.

Thanks for reporting that the different antenna inputs seem to have no
effect on the LNA performance!

Cheers,
Hermann





More information about the linux-dvb mailing list