[linux-dvb] saa7134-dvb: tda1004x: pll set failed

Mr misha volk anath3ma at yahoo.com
Tue Sep 11 16:59:29 CEST 2007


i have a very similar problem as the previous poster
however neither card=87 or 88 worked for me.  Any
clues?

The  Typhoon DVB-T Duo Digital/Analog PCMCIA card
lspci 
is:

0000:06:00.0 Multimedia controller: Philips
Semiconductors SAA7133 Video Broadcast Decoder (rev
f0)
        Subsystem: Unknown device 4e42:0502
        Flags: bus master, medium devsel, latency 64,
IRQ 11
        Memory at 26000000 (32-bit, non-prefetchable)
[size=2K]
        Capabilities: [40] Power Management version 2



If I insert the card, everything is fine for normal
analog TV. Dmesg tells me:
##########
[17185944.644000] pccard: CardBus card inserted into
slot 1
[17185944.644000] PCI: Enabling device 0000:06:00.0
(0000 -> 0002)
[17185944.644000] ACPI: PCI Interrupt 0000:06:00.0[A]
-> Link [C187] -> GSI 11 (level, low) -> IRQ 11
[17185944.644000] saa7133[0]: quirk: PCIPCI_NATOMA
[17185944.644000] saa7133[0]: found at 0000:06:00.0,
rev: 240, irq: 11, latency: 0, mmio: 0x26000000
[17185944.644000] PCI: Setting latency timer of device
0000:06:00.0 to 64
[17185944.644000] saa7133[0]: subsystem: 4e42:0502,
board: Typhoon DVB-T Duo Digital/Analog Cardbus
[card=60,autodetected]
[17185944.644000] saa7133[0]: board init: gpio is
e010000
[17185944.820000] tuner 1-004b: chip found @ 0x96
(saa7133[0])
[17185944.868000] tuner 1-004b: setting tuner address
to 61
[17185944.908000] tuner 1-004b: tuner: type set to
tda8290+75a
[17185945.004000] saa7133[0]: i2c eeprom 00: 42 4e 02
05 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[17185945.004000] saa7133[0]: i2c eeprom 10: 00 ff 22
0f ff 20 ff ff ff ff ff ff ff ff ff ff
[17185945.004000] saa7133[0]: i2c eeprom 20: 01 40 01
03 03 01 01 03 08 ff 01 81 ff ff ff ff
[17185945.004000] saa7133[0]: i2c eeprom 30: ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff ff
[17185945.004000] saa7133[0]: i2c eeprom 40: ff 25 00
c0 ff 10 07 01 c2 96 00 16 22 15 ff ff
[17185945.004000] saa7133[0]: i2c eeprom 50: ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff ff
[17185945.004000] saa7133[0]: i2c eeprom 60: ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff ff
[17185945.004000] saa7133[0]: i2c eeprom 70: ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff ff
[17185947.508000] saa7133[0]: registered device video0
[v4l2]
[17185947.508000] saa7133[0]: registered device vbi0
[17185947.508000] saa7133[0]: registered device radio0
[17185947.516000] DVB: registering new adapter
(saa7133[0]).
[17185947.516000] DVB: registering frontend 0 (Philips
TDA10046H DVB-T)...
[17185947.516000] saa7133[0]/alsa: saa7133[0] at
0x26000000 irq 11 registered as card -1


running kaffeine i get with dmesg:
[17186086.808000] tda1004x: found firmware revision ff
-- invalid
[17186086.976000] tda1004x: booting from eeprom
[17186087.520000] tda1004x: found firmware revision 23
-- ok
[17186087.948000] tda1004x: pll set failed
[17186120.220000] tda1004x: pll set failed

When i run the following:
sudo modprobe -r saa7134_alsa  saa7134; sudo modprobe
saa7134 card=88

I still get card=60.

[17188174.544000] saa7133[0]: subsystem: 4e42:0502,
board: Typhoon DVB-T Duo Digital/Analog Cardbus
[card=60,autodetected]

 uname -a:
Linux ubuntu 2.6.15-28-386 #1 PREEMPT Thu May 10
09:45:43 UTC 2007 i686 GNU/Linux

Thanks in advance for any help,
-michael




       
____________________________________________________________________________________
Pinpoint customers who are looking for what you sell. 
http://searchmarketing.yahoo.com/



More information about the linux-dvb mailing list