[linux-dvb] DiB0700 device report

Jonas Anden jonas at anden.nu
Sun Sep 30 20:00:21 CEST 2007


Update:

After closer verification, the Nova-TD Stick does not function properly
with the 1.10 firmware (either). tzap works and claims the frontend has
lock:

using '/dev/dvb/adapter3/frontend0' and '/dev/dvb/adapter3/demux0'
tuning to 490000000 Hz
video pid 0x03fb, audio pid 0x03fa
status 1e | signal ffff | snr 0000 | ber 001fffff | unc 00000133 | FE_HAS_LOCK
status 1a | signal ffff | snr 0000 | ber 001fffff | unc 00000946 | FE_HAS_LOCK
status 1e | signal ffff | snr 0000 | ber 00000000 | unc 000028a8 | FE_HAS_LOCK
status 1e | signal ffff | snr 0000 | ber 00010930 | unc 00002599 | FE_HAS_LOCK
status 1a | signal ffff | snr 0000 | ber 001fffff | unc 0000000b | FE_HAS_LOCK

But attempting to play the video stream generates errors (output from
'mplayer dvb://4@"TV6"'):

Playing dvb://4@SVT1.
dvb_tune Freq: 490000000
dvb_streaming_read, attempt N. 6 failed with errno 0 when reading 1484 bytes
dvb_streaming_read, attempt N. 5 failed with errno 0 when reading 1296 bytes
dvb_streaming_read, attempt N. 4 failed with errno 0 when reading 1296 bytes
...
MPlayer interrupted by signal 2 in module: demux_open

Attempting to tune to a channel with MythTV ends up in a "L__" state
(normally "LMS" after channel lock).

Signal levels are as follows (as reported by MythTV):
Nova-T Stick  53% (43%)
Nova-T 500(1) 59% (28%)
Nova-T 500(2) 67% (50%)

All devices are now being fed straight from a low-noise amplifier and
all are tuned to the same channel. Signal levels in parenthesis is with
internal LNA off (force_lna_activation=0).

  // J

On Sun, 2007-09-30 at 12:02 +0200, Jonas Anden wrote:
> > Can I ask you a few questions about the TD stick,
> > 
> > 1. How is reception compared to the nova-t 500
> 
> I think it is pretty similar, though I don't have any exact numbers to
> give you at this time. I'm going to do an overhaul of my cabling (with a
> better quality amplifier and splitter); I've got a small aerial antenna
> which is partially blocked by trees that feeds my four inputs and the
> current splitters and amplifier are pretty tacky, so any differences in
> reception is likely to be more dependent on the cabling than the tuners.
> I'll try to get back with better numbers when I have better surrounding
> equipment.
> 
> That being said, depending on which multiplex I tune to I have very
> varying reception on the Nova-T 500. My reception on mux 1 (with SVT
> channels) is usually between 70-80% according to MythTV (with the
> internal LNA enabled), while mux 5 (with the local channels) is varying
> from 40 to 60%.
> 
> > 2. What firmware do you use for it
> 
> I now use the 1.10 firmware. Using the 03-pre1 firmware I had similar
> problems to yours; dvbscan found plenty of channels but MythTV failed to
> get a lock.
> 
>   // J




More information about the linux-dvb mailing list