[linux-dvb] dvb-ttpci errors only on certain satellite channels

Johan van der Kolk johan.vanderkolk at gmail.com
Mon Aug 18 17:52:30 CEST 2008


On Mon, Aug 18, 2008 at 12:07 AM, Oliver Endriss <o.endriss at gmx.de> wrote:
>
> Johan van der Kolk wrote:
> > Hi
> >
> > I am getting this error, only when watching or recording certain
> > (unfortunately most of the dutch) satellite channels.
> >
> > The receiver card is a FF 2.1 Hauppauge (Nexus-s)
> >
> >  dmesg |tail
> > [ 8683.364276] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08cf b96a
> > ret 0  handle ffff
> > [ 8684.401584] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08d4 b96a
> > ret 0  handle ffff
> > [ 8685.436105] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08d5 b96a
> > ret 0  handle ffff
> > [ 8686.470599] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08d6 b96a
> > ret 0  handle ffff
> > [ 8687.506259] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08de b96a
> > ret 0  handle ffff
> > [ 8688.547456] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08df b96a
> > ret 0  handle ffff
> > [ 8689.581923] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08e0 b96a
> > ret 0  handle ffff
> > [ 8690.621384] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08e8 b96a
> > ret 0  handle ffff
> > [ 8691.662852] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08ed b96a
> > ret 0  handle ffff
> > [ 8692.697318] dvb-ttpci: StartHWFilter error  buf 0b07 0010 08f7 b96a
> > ret 0  handle ffff
> >
> >
> > I tried to eliminate common factors between working and erroneous
> > channels.
> > So far I think I ruled out....Symbol rate, FEC, frequency, transponder,
> > provider.
> >
> > In most cases the sequence repeats itself, sometimes after 2 errors,
> > sometimes
> > after more errors. Judging from the display quality, also the
> > signalstrength is good. (except from a thin horizontal line where the screen
> > seems to split)
> > I tried firmware versions d and f and use the latest v4l-dvb drivers
> >
> > dvb_core               81404  2 stv0299,dvb_ttpci
> > saa7146_vv             50304  1 dvb_ttpci
> > saa7146                20360  2 dvb_ttpci,saa7146_vv
> >
> > Since this happens every second, its filling up my logs quite well...I
> > cant even troubleshoot something else..
> >
> > Any help is greatly appreciated, even a suggestion for a good replacement
> > receiver card, if this is a problem with my card. It has to support 2 CI
> > interfaces though.
>
> First of all you should try a recent firmware.
> Please update the firmware to 2622 or to the lastest one
> http://www.suse.de/~werner/test_av-f12623.tar.bz2
>
> With current drivers the card should recover from an ARM crash.
>
> Most ARM crashes are caused by bad signal quality.
> Garbage data seems to crash the mpeg decoder of the card.
> Sorry, there is no fix for this problem.
>
> CU
> Oliver


I was on 2622 for months and went back to f then to d for testing,
forgot to mention the 2622.
I can watch TV for hours while the messages continue, so I had no idea
something was crashing.
It's just the errors that bug me. But if there's no fix, maybe I should
comment out that part of the code to get rid of the error messages.
Was just wondering what causes this, and only on some channels, not
others.
But i'll update to the last fw nevertheless and get back.

I was hoping to get some indication what goes wrong where. If it's
simple or specific to my card I might want to dig in and find a
solution. But I have a vague idea that it is way beyond my skills and
needs some serious knowledge about the way a TS stream is built and
how the software is currently decoding it.

thx

Johan



More information about the linux-dvb mailing list