[linux-dvb] TT S2-3200 + CI Extension

Martin Hurton martin.hurton at gmail.com
Wed Aug 27 11:19:48 CEST 2008


Hi Werner

On Tue, Aug 26, 2008 at 09:35:55PM +0200, Werner Hauger wrote:
> Hi Guys
> 
> What is the hardware revision of your CI board (printed on the bottom
> of the PCB just above the PCI connector)?

The revision of my CI board is 1.1.
> 
> I have a Rev 1.1 on my TT S2-3200 which requires polling, as well a
> Rev 1.0 on an old NOVA-S card which provides an interrupt, both of
> which work with the current driver. The version testing code was added
> to the driver to handle these two boards. Maybe there is a new
> revision out that the driver does not yet cater for.
> 
> A working CI and CAM combination should produce the following output
> when the driver loads:
> 
> Linux video capture interface: v2.00
> saa7146: register extension 'dvb'.
> saa7146: register extension 'budget_ci dvb'.
> ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
> PCI: setting IRQ 5 as level-triggered
> ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 5 (level,
> low) -> IRQ 5
> saa7146: found saa7146 @ mem d8ae8000 (revision 1, irq 5) (0x13c2,0x1019).
> saa7146 (0): dma buffer size 192512
> DVB: registering new adapter (TT-Budget S2-3200 PCI)
> adapter has MAC addr = 00:d0:5c:64:ba:14
> input: Budget-CI dvb ir receiver saa7146 (0) as
> /devices/pci0000:00/0000:00:09.0/input/input6
> budget_ci: CI interface initialised
> stb0899_get_dev_id: Device ID=[8], Release=[2]
> stb0899_get_dev_id: Demodulator Core ID=[DMD1], Version=[1]
> stb0899_get_dev_id: FEC Core ID=[FEC1], Version=[1]
> stb0899_attach: Attaching STB0899
> stb6100_attach: Attaching STB6100
> dvb_ca adapter 0: DVB CAM detected and initialised successfully
> DVB: registering frontend 0 (STB0899 Multistandard)...
> 
> > > 508     if ((ci_version & 0xa0) != 0xa0) {
> > > 509             result = -ENODEV;
> > > 510             goto error;
> > > 511     }
> > >
> 
> Martin, have you tried commenting out this test to see if you then can
> get the 'CI interface initialised' message?

When I comment out the above code, I can see the "CI interface
initialised" message, but cannot see the "dvb_ca adapter 0: DVB CAM
detected and initialised successfully" one. The CA is not working.
> 
> > Sorry I cannot offer any direct help. But I thought you might like to
> > know you are not the only one fighting with this piece of hardware :-)
> >
> > Roger
> 
> Roger, in your other message you said your CI board reports the
> version as 0xa0 which the driver expects to generate interrupts, which
> clearly it doesn't. Have you tried changing the code so that the
> driver uses polling for your CI version?
> 
> Werner

Do you know of any way to make sure the connection between TT-3200 and CI
board is working properly? 

Regards,
/Martin


> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb



More information about the linux-dvb mailing list