[linux-dvb] Live-TV picture goes away on composite out of ttpci

Marco Schinkel schinkelm at web.de
Mon Dec 8 13:42:54 CET 2008


Hello,

I experience some strange behavior with vdr and a plain full featured 
Technotrend Rev. 1.6 (no mods, no daughterboards, no usage of internal 
connectors):

When running VDR (version 1.6.0-2/1.6.0) after a few days the live tv on 
the composite out goes away (only black picture visible). The menu 
however is perfectly workable (and I can see it on the composite out on 
top of a black picture).

I use the newest available firmware and recent drivers from the v4l-dvb 
repository (using the v4l-dv-hg gentoo ebuild) on an 2.6.27.7 kernel.

dmesg output occasionally has the following message:

saa7146 (2) saa7146_i2c_writeout [irq]: timed out waiting for end of xfer

There are no other problems on the system, so I assume that it is either 
a dvb driver/firmware thing, or a vdr bug.

Starting a recording in vdr leads to an empty 001.vdr file. Restarting 
vdr does not help. Reloading the drivers usually helps but sometimes 
not. In this cases i have to powercycle the system. The problem exists 
no matter what card I use and on which position on the pci bus the card 
sits (I tried different cards, all ttpci 1.6 on 4 different slots on 3 
different pci busses). The problem even occured on my old mainboard 
occasionally. So it is definitely not a hardware defect. I assume the 
problem is not even related with the i2c timeout.

Is this problem known? Is there a known workaround or even better a way 
to fix this?


Best Regards,


Marco Schinkel





More information about the linux-dvb mailing list