[linux-dvb] Patch for analog part for Avermedia A700 fails to apply

Eduard Huguet eduardhc at gmail.com
Wed Feb 6 09:43:47 CET 2008


Ok, thanks for your tips. I guess I'll need to wait until Tino fixes his
patch. I tried yesterday using only yours but I didn't get a lock on any
channel.

By the way: with your DVB-S patch I got a new frontend / adaptor / etc...
set created. And here my problems started: this porks my current setup, as
the 2 adapters created by the Nova-T 500 appear now with a different
numbering schema.

Even worse, the actual numbering schema is different on a cold boot or on a
reboot:

cold boot:
  - dvb:0 -> Avermedia DVB-S
  - dvb:1, dvb:2 -> Nova-T 500

reboot:
  - dvb:0 -> Nova-T 500 first tuner
  - dvb:1 -> Avermedia DVB-S
  - dvb:2 -> Nova-T 500 second tuner

I guess that on cold boot the Nova-T 500 devices initialize later because of
the firmware loading.

¿Would you know (or whoever) how could I solve this and obligate someway the
system to use a fixed numbering schema for the DVB devices? Maybe you could
give me a hint, as it seems see you are a Gentoo developer (I'm using Gentoo
64 bits).

Best regards,
  Eduard





2008/2/5, Matthias Schwarzott <zzam at gentoo.org>:
>
> On Tuesday 05 February 2008, you wrote:
> > Hi,
>
> Hi!
>
> >     Bad news: I've been unsuccesfully trying to apply the new patches
> (as
> > mentioned in the wiki), with the following results:
> >
> > 1.- analog part applies just fine:
> >
> > mediacenter v4l-dvb # patch -p1 < ../1_avertv_A700_analog_part.diff
> > patching file linux/drivers/media/video/saa7134/saa7134-cards.c
> > patching file linux/drivers/media/video/saa7134/saa7134.h
> > patching file linux/Documentation/video4linux/CARDLIST.saa7134
> >
> It is just listed extra as this patch is the only one I think is correct
> and I
> hope it gets applied to v4l-dvb in near future. (Maybe after some others
> have
> verified it.)
>
> >
> > 2.- Your patch (ZZam's) gives some warnings:
> >
>
> >
> > Apparently the A700 section is duplicated. I assume that the second
> section
> > is the good one, as the first gives only option for analog input. This
> is
> > probably related to the patch no aplying cleanly. I've removed the 1st
> > section and now it seems to compile fine.
> >
> So you found out the hard way, that patch 1 (analog-only) is already part
> of
> my patch and you should only apply one of these.
>
> >
> > 3.- Tino's patch gets worse. It even doesn't apply:
> >
>
> I guess this patch is also influenced by some new added cards.
>
> Regards
>   Matthias
>
> --
> Matthias Schwarzott (zzam)
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080206/15360e13/attachment.htm 


More information about the linux-dvb mailing list