[linux-dvb] Any chance of help with v4l-dvb-experimental / Avermedia A16D please?

Mauro Carvalho Chehab mchehab at infradead.org
Tue Feb 12 15:47:34 CET 2008


On Sat, 09 Feb 2008 21:53:01 +0000
"Richard (MQ)" <osl2008 at googlemail.com> wrote:

> Richard (MQ) wrote:
> > Mauro Carvalho Chehab wrote:
> >> If you're not seeing any mesage from tuner-xc2028, it means that the driver is
> >> selecting a different tuner.
> >>
> >> Please send me the complete dmesg.
> >>
> >> Also, try to force saa7134 driver to use tuner=71 with:
> >>
> >> modprobe -vv saa7134 tuner=71
> > 
> > Please find attached - not posted to list as I don't think everyone will
> > want this...
> 
> Just tried re-booting the box with the standard OpenSuSE 10.3 partition,
> (and completely re-loaded and re-built the mercurial code) - same odd
> behaviour. Kernel now 2.6.22.16 fwiw
> 
> Also may be worth noting - running "make reload" after "make install"
> produces lots of errors, though neither the initial "make" nor "make
> install" gave any.
> 
> Output of "modprobe -vv saa7134 tuner=71" for this case attached
> (smaller than last time!)

The file got corrupted here :(

If you're getting too much errors, it may mean that you're having some
conflicts on your compilation.

There is a recent patch at the tree that changed the module dependencies.
(before the patch, videodev were dependent on v4l2-common - now, the dependency
is the reverse. Only after "make distclean", the building system will
correctly deal with this change)

Please try to do force a cleanup, with this:
make distclean
make
make rminstall
make rmmod
make install
modprobe saa7134 tuner=71

please forward the errors that it might produce. You may forward the full dmesg
errors to me in priv directly. I prefer if you don't generate a tarball, since
makes easier for me to comment, the results, if needed.

Cheers,
Mauro



More information about the linux-dvb mailing list