[linux-dvb] Perfect kernel/drivers for the Nova-T stick

Ysangkok ysangkok at gmail.com
Sun Feb 24 20:25:29 CET 2008


Hello Simeon,

So you're saying that if I want to get my Nova-T stick to work I
should compile 2.6.22.9 instead of 2.6.24.2?

I, too, have a Nova-T stick. I'm using the default Ubuntu kernel, and
git linux-dvb tree. However, it doesn't currently work.

Regards,
Janus Troelsen

2008/2/24, Simeon Walker <simbloke at googlemail.com>:
> Hi,
>
> No, this isn't a question, for me I have the answer, and it is
> 2.6.22.18, the kernel drivers and the latest firmware.
>
> I am using Ubuntu Gutsy and started with their included 2.6.22 kernel.
> When I got the Nova-T stick (now two) I tried the stock Ubuntu kernel
> with no luck. I then tried the linux-dvb drivers with the stock
> kernel. The drivers worked but there was massive stream corruption.
>
> Since then I tried 2.6.23, 2.6.23.13, 2.6.24 (inc .1 and .2). With all
> these versions I have had the dvb-usb driver sometimes complaining
> about the stick being on a USB 1.1 bus, a reboot always fixed that.
> All these version had some problems with mt2060 i2c errors. Sometimes
> I would get USB disconnects, the driver would reload but MythTV
> doesn't even notice it's not recording anymore.
>
> Finally, I don't know why, I tried compiling the latest 2.6.22 kernel.
> The differences are:
>  - There is no stream corruption like the Ubuntu 2.6.22 kernel.
>  - USB2 mode works on every boot.
>  - There are no USB disconnects.
>  - There are no I2C errors.
> The system has been completely stable for for two weeks with not
> single instance of the previous errors.
>
> Is it just me or has anyone else had luck with this kernel version?
>
> Sim
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>



More information about the linux-dvb mailing list