[linux-dvb] Pinnacle 800i driver problems

superhappyfunball superhappyfunball at gmail.com
Thu Jan 24 01:29:47 CET 2008


Muppet Man wrote:

 > Ok, I did the sudo make rminstall and rm rf v4l-dvb, downloaded the
 > file from the link, extracted, cd, sudo make, sudo make install,
 > rebooted, and still had the same problem

Indeed. I even made sure the old modules were completely wiped before I 
installed a clean set of modules from mercurial.

In short...

[   50.272060] cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.6 loaded
[   50.272223] cx88[0]: subsystem: 11bd:0051, board: Pinnacle PCTV HD 
800i [card=58,autodetected]
[   50.272294] cx88[0]: TV tuner type 76, Radio tuner type -1
[   50.418386] input: cx88 IR (Pinnacle PCTV HD 800i) as /class/input/input6
[   50.418494] cx88[0]/2: cx2388x 8802 Driver Manager
[   50.418685] cx88[0]/2: found at 0000:02:02.2, rev: 5, irq: 18, 
latency: 32, mmio: 0xf4000000
[   50.615427] cx88/0: cx2388x v4l2 driver version 0.0.6 loaded
[   50.615675] cx88[0]/0: found at 0000:02:02.0, rev: 5, irq: 18, 
latency: 32, mmio: 0xf2000000
[   51.253871] cx88/2: cx2388x dvb driver version 0.0.6 loaded
[   51.253935] cx88/2: registering cx8802 driver, type: dvb access: shared
[   51.254792] cx88[0]/2: subsystem: 11bd:0051, board: Pinnacle PCTV HD 
800i [card=58]
[   51.254861] cx88[0]/2: cx2388x based DVB/ATSC card
[   52.343530] tuner' 0-0064: chip found @ 0xc8 (cx88[0])
[   52.375709] DVB: registering new adapter (cx88[0])
[   52.458249] Modules linked in: snd_mpu401 snd_mpu401_uart snd_emu10k1 
snd_ac97_codec ac97_bus snd_util_mem snd_seq_midi snd_hwdep 
snd_seq_dummy s5h1409 snd_seq_oss tuner tea576$
[   52.465209]  [<f8a1dbc0>] cx88_tuner_callback+0x0/0x60 [cx88xx]
[   52.465537]  [<f8a1fcee>] attach_inform+0xee/0x180 [cx88xx]
[   52.465664]  [<f8a1dbc0>] cx88_tuner_callback+0x0/0x60 [cx88xx]
[   52.470649] cx88[0]/0: registered device video0 [v4l2]
[   52.470759] cx88[0]/0: registered device vbi0
[   52.476241] cx88[0]/1: CX88x/0: ALSA support for cx2388x boards


The only way I could get this dmesg output, was to boot off the recovery 
kernel. Even under the recovery kernel, attempting to start or load X in 
any way (kdm, gdm, or startx) results in a complete and utter 
crash/freeze. You cannot get out of it without a system reset. You can't 
  even get into an alternate tty to kill the process. It just locks.

I guess my question at this point is twofold:

1) is this, as Steve suggested earlier, a problem with core videobuf? Or 
is it the nVidia driver? The hang point seems to be when nVidia gets 
invoked and X Starts. kdm/gdm do not even seem to get a chance to load.

2) What, if anything can I do to get it to work, or help you guys figure 
out where the problem is? I am open to being a guinea pig in any way I 
can to help get this solved. =)

The compile runs fine. The modules install fine. Something else is amiss.

Christopher.

-- 
"Do not taunt Happy Fun Ball"
superhappyfunball at gmail.com

"You fiend! Never have I encountered such corrupt and foul-minded 
perversity! Have you ever considered a career in the church?" -- Bishop 
of Bath and Wells



More information about the linux-dvb mailing list