[linux-dvb] Leadtek WinFast DTV Dongle Gold Remote issues

Alistair M tlli at hotmail.com
Thu Jul 3 23:50:31 CEST 2008



Hi Antii,

I'm sorry, its still doing it. I'm doing the following:
# hg clone http://linuxtv.org/hg/~anttip/af9015-new
# cd af9015-new
# make
# make install
reboot

I then open terminal, with the usb stick plugged in, i hit the number 5 on the remote, then 5 gets printed on the terminal screen, and is repeated continuously, eg. 5555555555555555555555555555.... until i hit another key. If i use the number 5 from the keyboard when i type something, it will do the same again, 55555555555555555555555555555555.....

This happens for what ever number i press on the remote, it will then do on my laptop keyboard, etc.

Thanks Antii,
Alistair


> Date: Thu, 3 Jul 2008 17:58:25 +0300
> From: crope at iki.fi
> To: tlli at hotmail.com
> CC: linux-dvb at linuxtv.org
> Subject: Re: [linux-dvb] Leadtek WinFast DTV Dongle Gold Remote issues
> 
> should be fixed now!
> 
> regards
> Antti
> 
> Alistair M wrote:
> > Ah great news...!
> > 
> >  > Date: Thu, 3 Jul 2008 17:04:18 +0300
> >  > From: crope at iki.fi
> >  > To: tlli at hotmail.com
> >  > CC: linux-dvb at linuxtv.org
> >  > Subject: Re: [linux-dvb] Leadtek WinFast DTV Dongle Gold Remote issues
> >  >
> >  > Alistair M wrote:
> >  > > Hello Antii,
> >  > > I have compiled in your latest build.
> >  > >
> >  > > What seems to be happening is, in the terminal or even a text editor,
> >  > > when i press any button on the remote control, that character (eg. 0)
> >  > > will be repeated as text on the terminal or text editor. So if i for
> >  > > instance press the key 0 on the remote, while i have a text editor 
> > open,
> >  > > it enters the number 0 continuously, like this:
> >  > > 000000000000000000000000000000... in the editor, or terminal 
> > window, or
> >  > > any text input field.
> >  >
> >  > hmm, I think I know the reason. Actually this is due to hardware bug. I
> >  > think I have older silicon revision that returns error code when polling
> >  > remote events and there is no event. You have a newer silicon that does
> >  > not return error any more. Current remote polling code in the driver
> >  > relies that error code. I will fix that soon, it is easy to fix.
> >  >
> >  > > Does that make sense...
> >  > > Its past midnight here in Australia so i have to get to bed as i 
> > have to
> >  > > work tomorrow, i'll email back in the morning.
> >  > > Thank you Antii.
> >  > > Alistair.
> >  >
> >  > regards
> >  > Antti
> >  > --
> >  > http://palosaari.fi/
> > 
> > ------------------------------------------------------------------------
> > Find a new job on Seek Increase your salary. 
> > <http://a.ninemsn.com.au/b.aspx?URL=http%3A%2F%2Fninemsn%2Eseek%2Ecom%2Eau%2F%3Ftracking%3Dsk%3Amtl%3Ask%3Anine%3A0%3Ahot%3Atext&_t=764565661&_r=JAN08_endtext_increase&_m=EXT>
> > 
> > 
> > ------------------------------------------------------------------------
> > 
> > _______________________________________________
> > linux-dvb mailing list
> > linux-dvb at linuxtv.org
> > http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 
> 
> -- 
> http://palosaari.fi/

_________________________________________________________________
What are you waiting for? Join Lavalife FREE
http://a.ninemsn.com.au/b.aspx?URL=http%3A%2F%2Flavalife9%2Eninemsn%2Ecom%2Eau%2Fclickthru%2Fclickthru%2Eact%3Fid%3Dninemsn%26context%3Dan99%26locale%3Den%5FAU%26a%3D30288&_t=764581033&_r=email_taglines_Join_free_OCT07&_m=EXT
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080704/e87ca0f4/attachment-0001.htm 


More information about the linux-dvb mailing list