[linux-dvb] Failure: Ubuntu users, rejoyce!-Aver hybrid dvb-s+fm A700 - Ubuntu 8.04 - card=141 autodetect

bvidinli bvidinli at gmail.com
Thu Jun 12 23:06:29 CEST 2008


i updated dvb_ubuntu.sh script to reflect zzam's latest patch of
http://dev.gentoo.org/~zzam/dvb/a700_full_20080604.diff


2008/6/13 bvidinli <bvidinli at gmail.com>:
> as i stated before,
> my card is aver hybrid dvb-s + fm A700
> which is autodetected by this new driver of v4l-dvb for ubuntu...
>
> autoloaded module is saa7134, card type=141
> Currently dmesg output is below, but i am unable to even see dvb
> device/or dvb channel list in kaffeine, kaffeine says no dvb device
> available,
>
>
> previously, i had builded v4l-dvb in my ubuntu 8.04, then put *.ko
> files to related places with a small script i made, which i attached
> in this mail.
> with that script or method, i was able to see dvb in kaffeine, and i
> was able to see channel list, but not able to watch channels...
>
> i would be happy if you fix v4l driver install/build on ubuntu, or say
> us a way of using our dvb devices...
>
> dmesg related output:
> [   49.551593] saa7133[0]: found at 0000:00:14.0, rev: 209, irq: 10,
> latency: 32, mmio: 0xde003000
> [   49.551611] saa7133[0]: subsystem: 1461:a7a2, board: Avermedia
> DVB-S Hybrid+FM A700 [card=141,autodetected]
> [   49.551631] saa7133[0]: board init: gpio is 2f200
> [   49.551642] saa7133[0]: Avermedia DVB-S Hybrid+FM A700: hybrid
> analog/dvb card
> [   49.551648] saa7133[0]: Sorry, only the analog inputs are supported for now.
> [   49.935937] irda_init()
> [   49.935987] NET: Registered protocol family 23
> [   50.231787] saa7133[0]: i2c eeprom 00: 61 14 a2 a7 ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231817] saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231840] saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231864] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231887] saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231909] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231932] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231955] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.231978] saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.232001] saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.232023] saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.232046] saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.232069] saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.232092] saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.232114] saa7133[0]: i2c eeprom e0: 00 01 81 af fe f6 ff ff ff
> ff ff ff ff ff ff ff
> [   50.232137] saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff
> ff ff ff ff ff ff ff
> [   50.296062] saa7133[0]: registered device video0 [v4l2]
> [   50.296148] saa7133[0]: registered device vbi0
> [   50.296375] via-ircc: dongle probing not supported, please specify
> dongle_id module parameter.
> [   50.297266] IrDA: Registered device irda0 (via-ircc)
> [   51.428409] saa7134_alsa: disagrees about version of symbol
> saa7134_tvaudio_setmute
> [   51.428428] saa7134_alsa: Unknown symbol saa7134_tvaudio_setmute
> [   51.428829] saa7134_alsa: disagrees about version of symbol saa_dsp_writel
> [   51.428838] saa7134_alsa: Unknown symbol saa_dsp_writel
> [   51.429344] saa7134_alsa: disagrees about version of symbol videobuf_dma_free
> [   51.429352] saa7134_alsa: Unknown symbol videobuf_dma_free
> [   51.429862] saa7134_alsa: disagrees about version of symbol
> saa7134_pgtable_alloc
> [   51.429871] saa7134_alsa: Unknown symbol saa7134_pgtable_alloc
> [   51.430018] saa7134_alsa: disagrees about version of symbol
> saa7134_pgtable_build
> [   51.430027] saa7134_alsa: Unknown symbol saa7134_pgtable_build
> [   51.430154] saa7134_alsa: disagrees about version of symbol
> saa7134_pgtable_free
> [   51.430163] saa7134_alsa: Unknown symbol saa7134_pgtable_free
> [   51.430291] saa7134_alsa: disagrees about version of symbol
> saa7134_dmasound_init
> [   51.430300] saa7134_alsa: Unknown symbol saa7134_dmasound_init
> [   51.430679] saa7134_alsa: disagrees about version of symbol
> saa7134_dmasound_exit
> [   51.430688] saa7134_alsa: Unknown symbol saa7134_dmasound_exit
> [   51.430972] saa7134_alsa: disagrees about version of symbol videobuf_dma_init
> [   51.430981] saa7134_alsa: Unknown symbol videobuf_dma_init
> [   51.431391] saa7134_alsa: disagrees about version of symbol
> videobuf_dma_init_kernel
> [   51.431401] saa7134_alsa: Unknown symbol videobuf_dma_init_kernel
> [   51.431848] saa7134_alsa: Unknown symbol videobuf_pci_dma_unmap
> [   51.432291] saa7134_alsa: Unknown symbol videobuf_pci_dma_map
> [   51.432458] saa7134_alsa: disagrees about version of symbol
> saa7134_set_dmabits
> [   51.432467] saa7134_alsa: Unknown symbol saa7134_set_dmabits
>
>
> 2008/6/11 Martin Pitt <martin.pitt at ubuntu.com>:
>> Hi,
>>
>> bvidinli [2008-06-11 13:42 +0300]:
>>> [   48.655559] saa7134_alsa: Unknown symbol saa7134_tvaudio_setmute
>>> [   48.655959] saa7134_alsa: disagrees about version of symbol saa_dsp_writel
>>
>> Ah, AFAIK linux-ubuntu-modules ships a newer version of ALSA than the
>> linux kernel itself. Ubuntu ships the headers for those as well
>> (linux-headers-lum-2.6.24-19-generic, or
>> linux-headers-lum-2.6.24-18-generic if you don't run hardy-proposed).
>> Thus v4l-dvb needs to be built against those headers.
>>
>> However, merely installing the package won't magically make them used
>> by the build. Maybe it helps to pass
>> EXTRA_CFLAGS="-I /usr/src/linux-headers-lum-2.6.24-19-generic" (or
>> -18, respectively) to the MAKE[0] command in
>> /usr/src/v4l-dvb-0.20080610/dkms.conf? If that helps, I can generalize
>> it.
>>
>> Also/Alternatively, if you can tell me which module you tried to load
>> for your card, then I can try to reproduce it locally.
>>
>> Thanks,
>>
>> Martin
>>
>> --
>> Martin Pitt                        | http://www.piware.de
>> Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
>>
>
>
>
> --
> İ.Bahattin Vidinli
> Elk-Elektronik Müh.
> -------------------
> iletisim bilgileri (Tercih sirasina gore):
> skype: bvidinli (sesli gorusme icin, www.skype.com)
> msn: bvidinli at iyibirisi.com
> yahoo: bvidinli
>
> +90.532.7990607
> +90.505.5667711
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>



-- 
İ.Bahattin Vidinli
Elk-Elektronik Müh.
-------------------
iletisim bilgileri (Tercih sirasina gore):
skype: bvidinli (sesli gorusme icin, www.skype.com)
msn: bvidinli at iyibirisi.com
yahoo: bvidinli

+90.532.7990607
+90.505.5667711
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dvb_ubuntu.sh
Type: application/x-sh
Size: 2812 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080613/e3706ef2/attachment.sh 


More information about the linux-dvb mailing list