[linux-dvb] HVR-1800 failing to detect any QAM256 channels

Eric Cronin ecronin at gizmolabs.org
Thu May 1 05:19:49 CEST 2008


On Apr 30, 2008, at 8:20 PM, Michael Krufky wrote:
> Eric Cronin wrote:
>>
>> On Apr 30, 2008, at 2:36 PM, Michael Krufky wrote:
>>
>>>>
>>>> Eric,
>>>>
>>>> When you use the scan command to scan for QAM channels, you must
>>>> specify -a2, to signify that you are scanning digital cable.
>>>>
>>>> Try that -- does that work?
>>>
>>>
>>> My bad -- I meant, "-A 2"  (capitol A, space, 2)
>
> scan -A 2 -vvv dvb-apps/util/scan/atsc/us-Cable-Standard-whatever >
> channels.conf
>
> Is THAT what you're doing to scan ?
>
>
> It looks like what you were doing was scan a tuned frequency for pids.
> If you want to do THAT, then you must actually be tuned to the given
> frequency.  you need to azap SOME_CHANNEL -r, and keep that running
> before attempting to run 'scan -c' ...  I think you should try the  
> scan
> command that I mentioned above.
>
> HTH,
>
> Mike
>


I was only using one -v, but the scan file isn't the problem.  It is  
just the single line out of /usr/share/doc/dvb-utils/examples/scan/ 
atsc/us-Cable-Standard-center-frequencies-QAM256 corresponding to a  
known good frequency.  Otherwise it scans from 0-70 which are all NTSC  
and gets annoying on repeated attempts...

Adding two more -v's doesn't change anything, status is always 0x00  
and nothing gets written to STDOUT (channels.conf)

~$ scan -A 2 -vvv /usr/share/doc/dvb-utils/examples/scan/atsc/us-Cable- 
Standard-center-frequencies-QAM256 > channels.conf
scanning /usr/share/doc/dvb-utils/examples/scan/atsc/us-Cable-Standard- 
center-frequencies-QAM256
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
 >>> tune to: 57000000:QAM_256
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
WARNING: >>> tuning failed!!!

...

 >>> tune to: 801000000:QAM_256 (tuning failed)
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)
Done.

~$ wc channels.conf
0 0 0 channels.conf

Thanks,
Eric
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 486 bytes
Desc: This is a digitally signed message part
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080430/2e13a182/attachment-0001.pgp 


More information about the linux-dvb mailing list