[linux-dvb] [PATCH 1/7] Adding empia base driver

Mauro Carvalho Chehab mchehab at infradead.org
Sat Nov 8 11:15:08 CET 2008


On Sat, 8 Nov 2008 03:50:20 -0200
"Andre Kelmanson" <akelmanson at gmail.com> wrote:

> Dears,
> 
> I'm using this version of em28xx for a long time and it's working fine. It
> has three very important features for me. The first one is Kaiomy device,
> the second one is the new em28xx-audoep module and the third one is PAL-M
> support. Kaiomy and PAL-M support were developed based on my support on the
> em28xx mailinglist.
> 
> Now I can use my device (Kaiomy) outside Windows with sound (em28xx-audioep)
> and colors (PAL-M)! I'm using this version everyday with no problems.
> 
> Because of this, it will be nice if this work could be included in the
> kernel code. What do you (other users) think about having that driver in
> kernel?

André,

First of all, the big issue why we aren't merging em28xx improvements from
Markus is that he is not following the rules.

For example, you said that you've contributed with Markus tree.

However, on Markus pull request, I see no patch from you on his series of patches. 

The correct procedure would be just to forward your patch as-is, adding with his SOB bellow yours.

Not doing this, he would be considered as the author of your patch. IANAL, but
this doesn't seem to be right, from GPL's perspective. Probably, there are
other patches there not authored by Markus that are just merged inside his big patch.

About PAL-M, this always worked at the upstream driver. I have myself lots of
em28xx devices, all working in colors with PAL-M, and with audio. I live in
Brazil, so I always check if PAL-M is ok ;)

If you want to have your device supported, just send us a patch against the
upstream driver.

Cheers,
Mauro



More information about the linux-dvb mailing list