[linux-dvb] Technisat Skystar Revision 2.8 broken in kernel 2.6.28-rc1

Patrick Boettcher patrick.boettcher at desy.de
Fri Oct 24 20:39:25 CEST 2008


Hi,

On Fri, 24 Oct 2008, sinter.mann at gmx.de wrote:
> Hi everybody,
>
> neither with the latest Mercurial tree from linuxtv.org nor within the 
> latest kernel 2.6.28-rc1 the Technisat Skystar DVB-S card is usable.
>
> To resolve this as an intermediate solution I appended 2 patchsets as 
> outline attachment:
>
> a. skystar2_rev2.8.tar.bz2: the basic patch to run this card with a 
> current kernel >= 2.6.27 - including a self-written docu and patches by 
> Patrick Boettcher plus a precompiled cx24113 module, because this part 
> is still not GPL
>
> b. skystar2628.diff: A reversion concerning modules dvb_frontend.c and 
> dvb_frontend.h: Without that reversion that card runs excellently under 
> kernel 2.6.27. With that reversion that card runs excellently under 
> 2.6.28-rc1.

As part of this driver (cx24113) is a out-of-tree driver and even worse 
only available as a binary, please also request support from Technisat. 
They should handle that for the user who does not want to patch his 
kernel.

best regards,
Patrick.



More information about the linux-dvb mailing list