[linux-dvb] Terratec Cinergy C PCI HD

Andreas Lindkvist andreas at acc.umu.se
Sun Oct 26 19:29:08 CET 2008


Hi
Im am trying to get my Cinergy C PCI card to work using the following wiki:

   http://www.linuxtv.org/wiki/index.php/TerraTec_Cinergy_C_DVB-C

The problem is that I get the following "error" when running 
"modprobe mantis":

   found a UNKNOWN PCI UNKNOWN device on (01:06.0),
       Mantis Rev 1 [153b:0178], irq: 19, latency: 96
       memory: 0xebfff000, mmio: 0xf88fe000
       MAC Address=[ff:ff:ff:ff:ff:ff]

When running lspci i get the following information:

> lspci -v -s 01:06.0

   01:06.0 Multimedia controller: Twinhan Technology Co. Ltd Mantis DTV PCI
         Bridge Controller [Ver 1.0] (rev 01)
         Subsystem: TERRATEC Electronic GmbH Device 0178
         Flags: bus master, medium devsel, latency 96, IRQ 19
         Memory at ebfff000 (32-bit, prefetchable) [size=4K]
         Kernel driver in use: Mantis
         Kernel modules: mantis

> lspci -vvn -s 01:06.0

01:06.0 0480: 1822:4e35 (rev 01)
         Subsystem: 153b:0178
         Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR+ FastB2B- DisINTx-
         Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR+ <PERR+ INTx-
         Latency: 96 (2000ns min, 59750ns max)
         Interrupt: pin A routed to IRQ 19
         Region 0: Memory at ebfff000 (32-bit, prefetchable) [size=4K]
         Kernel driver in use: Mantis
         Kernel modules: mantis

which is not the same as the ID on the wiki page:

$ lspci -vvn -s 01:01.0
01:01.0 0480: 1822:4e35 (rev 01)
         Subsystem: 153b:1178
         Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
         Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort+ <MAbort- >SERR- <PERR-
         Latency: 64 (2000ns min, 63750ns max)
         Interrupt: pin A routed to IRQ 22
         Region 0: Memory at cfdff000 (32-bit, prefetchable) [size=4K]

Is this another version of the card not supported by the driver or am I 
missing something or doing something wrong?

I am greatful for any help.

Regards,

   Andreas



More information about the linux-dvb mailing list