[linux-dvb] TV713X Remote Control

Miguel Ángel Fernández mianfel at hotmail.com
Thu Nov 25 19:11:41 CET 2010


Hello!

I have a remote almost running. My DVB-T card works fine to watch and record TV with MythTV and Kaffeine.

But I'm a newbie and I would need some help with my remote. I'm about to find the solution but
I don't know the next step of the process.

My system is:
Remote: TV713X
TV-Card: Conceptronic CTVCOMBOi (detected as Tevion/KWorld DVB-T 220RF)
Receiver: bundled in the TV-Card
Software: Ubuntu 9.04

dmesg:

[    8.932913] saa7130/34: v4l2 driver version 0.2.14 loaded
[    8.933488] saa7134 0000:01:06.0: PCI INT A -> Link[LNKA] -> GSI 19 (level, low) -> IRQ 19
[    8.933494] saa7133[0]: found at 0000:01:06.0, rev: 209, irq: 19, latency: 64, mmio: 0xdffff800
[    8.933499] saa7133[0]: subsystem: 17de:7201, board: Tevion/KWorld DVB-T 220RF [card=88,autodetected]
[    8.933536] saa7133[0]: board init: gpio is 100
[    9.084512] saa7133[0]: i2c eeprom 00: de 17 01 72 ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084519] saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084525] saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084530] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084535] saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084540] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084545] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084550] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084556] saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084561] saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084566] saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084571] saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084576] saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084581] saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084586] saa7133[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[    9.084592] saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff


sudo irw
connect: No such file or directory


Loaded TV-Card modules:
tda1004x               26244  1 
saa7134_dvb            32268  1 
videobuf_dvb           16516  1 saa7134_dvb
saa7134_alsa           22176  0 
dvb_core              106924  2 saa7134_dvb,videobuf_dvb
tda827x                18948  2 
tda8290                23428  1 
tuner                  36036  0 
saa7134               176988  2 saa7134_dvb,saa7134_alsa
ir_common              56068  1 saa7134
compat_ioctl32         18176  1 saa7134
videodev               45184  3 tuner,saa7134,compat_ioctl32
v4l1_compat            23940  1 videodev
v4l2_common            23296  2 tuner,saa7134
videobuf_dma_sg        22660  3 saa7134_dvb,saa7134_alsa,saa7134
videobuf_core          29828  3 videobuf_dvb,saa7134,videobuf_dma_sg
tveeprom               23428  1 saa7134




And, the most important I could see is when I load "ir-kbd-i2c"
sudo modprobe ir-kbd-i2c
WARNING: All config files need .conf: /etc/modprobe.d/oss-compat, it will be ignored in a future release.

The output in dmesg is:
[  374.444695] input: i2c IR (KNC One) as /devices/virtual/input/input6
[  374.472666] ir-kbd-i2c: i2c IR (KNC One) detected at i2c-0/0-0030/ir0 [saa7133[0]]

And, what is more. Only when the module is loaded, if I push some buttons of the remote I have this
output in dmesg:
[  450.228029] i2c IR (KNC One): unknown key: key=0x03 raw=0x03 down=1
[  450.288526] i2c IR (KNC One): unknown key: key=0x03 raw=0x03 down=0
[  451.248534] i2c IR (KNC One): unknown key: key=0x00 raw=0x00 down=1
[  451.308027] i2c IR (KNC One): unknown key: key=0x00 raw=0x00 down=0

But irw has this output:
sudo irw
connect: No such file or directory

I think the remote is almost working because I have a new output in dmesg every time
I push a button. I don't know why "irw" can't connect and I don't know if I need it.

I hope someone could show me the way or the next couple of steps in the configuration of the remote. And
where to config the module to be autoloaded in boot time.

Sorry for such a big mail, I've thought that all information could be usefull.

Thanks!!!
 		 	   		  


More information about the linux-dvb mailing list