[vdr] xine vdpau not working?

Jiri Dobry jdobry at centrum.cz
Sun Jan 10 09:38:36 CET 2010


Hello,

xine-lib must be patched, patch for this you can found on xine plug in
directory.
It add connection between vdr&xine

Except this xineliboutput plug in with external frontend (vdr-sxfe
included in this plugin) it more useful a don't have problems with
jumping on video&sound.

I have another problem when ANY version of xine&VDPAU drop video frames.
Some HW is better, some is worst. It happen when PC is under heavy load
(example compilation on background).

run xine (vdr-sxfe) with "nice -n -20" help little bit but problem still
exist.

Worst situation is HD 1080i video on integrated Nv6300, it drop around
90% of frames.

Yes, I am sure that VDPAU is used, and I am not use any video filter
except deinterlacer in VDPAU.

Details: http://www.nvnews.net/vbulletin/showthread.php?p=2134207

Jiri



Date: Sat, 9 Jan 2010 12:25:51 +1300
From: "Simon Baxter" <linuxtv at nzbaxters.com>
Subject: [vdr] xine vdpau not working?
To: "VDR Mailing List" <vdr at linuxtv.org>
Message-ID: <F1F6345059674EFDBDF37E46E863BBC8 at ad.sytec.com>
Content-Type: text/plain; charset="iso-8859-1"; Format="flowed"

Hi

This is more related to xine than VDR, but I can't get vdpau to work on my
VDR box.  Everything appears to compile fine, but if I do:
xine --list-plugins | grep vdpau
I get nothing.

I can start xine with :
xine --verbose=2 -V vdpau -A alsa --post vdr_video --post 001.vdr
but it plays in xv "video_out_xv" (see attached)

I can even start with xine --verbose=2 -V biggirlsblouse -A alsa --post
vdr_video --post vdr_audio --post upmix_mono 001.vdr
and it still plays in xv with no errors.

ANY IDEAS??



I'm using xine-lib-1.2 and patching with xine-lib-1.2-vdpau-r286.diff which
was configured with:
./autogen.sh --with-vdpau --enable-debug --disable-optimizations 
--with-mpc=no

then using xine-ui xine-ui-cvs-20090617220000 built with
./autogen.sh --enable-vdr-keys --disable-lirc

My only library plugins are now xine-lib-1.2:
ldconfig -p | grep xine
        libxine.so.2 (libc6,x86-64) => /usr/local/lib/libxine.so.2
        libxine.so (libc6,x86-64) => /usr/local/lib/libxine.so

ls -l /usr/local/lib/libxine*
-rwxr-xr-x 1 root root     825 2010-01-09 11:59 /usr/local/lib/libxine.la
lrwxrwxrwx 1 root root      16 2010-01-09 11:59 
/usr/local/lib/libxine.so ->
libxine.so.2.0.0
lrwxrwxrwx 1 root root      16 2010-01-09 11:59
/usr/local/lib/libxine.so.2 -> libxine.so.2.0.0
-rwxr-xr-x 1 root root 1118042 2010-01-09 11:59
/usr/local/lib/libxine.so.2.0.0

Kernel is:
2.6.27.29-170.2.78.fc10.x86_64

nvidia drivers are:
kmod-nvidia-2.6.27.29-170.2.78.fc10.x86_64-180.60-1.fc10.1.x86_64
xorg-x11-drv-nvidia-libs-180.60-1.fc10.x86_64

Video card is:
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce
430 (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Giga-byte Technology Device d000
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        Memory at f2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f3000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at 50000000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+
Count=1/1 Enable-
        Kernel driver in use: nvidia
        Kernel modules: nvidia, nvidiafb


Any ideas??  What am I doing wrong?


Thanks
Simon





More information about the vdr mailing list