[vdr] Applying dxr3 subtitles patch to debian packages

Emyr Thomas emyr.thomas at gmail.com
Tue Jan 26 14:00:40 CET 2010


I've built a Debian (Lenny) based VDR machine. I installed VDR from
the Debian VDR and DVB Packaging Project[1] following the instructions
described here:
http://www.linuxtv.org/vdrwiki/index.php/DEBIAN_Compiling_VDR_Source_Packages

I had some problems with the packaged dxr3 drivers and plugin, so I
manually compiled and installed the dxr3 drivers[2] (version 0.18.0)
and the VDR dxr3 plugin[3] (version 0.2.10). Everything is working
very well so far except for subtitles - I get tearing and corruption
when they are displayed. I know subtitles have a problematic history
on the dxr3 device, but I noticed in the VDR dxr3 plugin sources there
is a patch for VDR to fix this[4].

My question is, given the way I've installed VDR, what's the
best/easiest way for me to apply this patch? Do I have to compile VDR
from source myself, or can I somehow modify the debian VDR package
sources on my machine and build them with this patch applied?

Apologies if I'm not making much sense, I'm fairly new to this.

Thanks for your help!

--Emyr

[1] http://pkg-vdr-dvb.alioth.debian.org/
[2] http://dxr3.sourceforge.net/
[3] http://sourceforge.net/projects/dxr3plugin/
[4] http://projects.vdr-developer.org/repositories/changes/plg-dxr3/patches/vdr-dxr3subtitlehack.patch



More information about the vdr mailing list