[vdr] [PATCH] Gather necessary options for build in Make.global and include it.

Paul Menzel paulepanter at users.sourceforge.net
Sat Jan 30 12:12:19 CET 2010


Am Samstag, den 30.01.2010, 11:57 +0100 schrieb Udo Richter:
> Am 28.01.2010 22:52, schrieb Ville Skyttä:
> > On Thursday 28 January 2010, Paul Menzel wrote:
> > 
> >> Therefore include strictly necessary options in `Make.global` and include
> >>  this in all the Makefiles before `Make.config`.
> > 
> > If these options are strictly necessary, shouldn't the leading "-" be dropped 
> > from all "-include $(VDRDIR)/Make.global" lines?
> 
> In this case, yes, but many cross-version plugins will need to be more
> flexible here, either by doing a messy VDR version check, or by simply
> just using -inlcude anyway.

Sorry, I do not know if I understood you correctly. Do you mean that
some other plugins (which are not shipped with VDR, i. e. the patch does
not need to be changed in that regard) need to use `-include
$(VDRDIR)/Make.global` instead of `include $(VDRDIR)/Make.global`?

Do the authors of those plugins generally know about that kind of stuff
or does this have to be documented somewhere?


Thanks,

Paul
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
URL: <http://www.linuxtv.org/pipermail/vdr/attachments/20100130/4772c8dc/attachment.pgp>


More information about the vdr mailing list